LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Pam-mount on 12.04 LTS (http://www.linuxquestions.org/questions/linux-server-73/pam-mount-on-12-04-lts-4175452364/)

vikfreeze 03-02-2013 04:31 AM

Pam-mount on 12.04 LTS
 
Hi,

im trying to configure libpam-mount to mount user homes when a user logs in via freenx, this worked on 10.04 LTS but pam is not playing along on 12.04.

The problems come from the way pam-mount is invoked in pam, at first it only invoked for the nx user and not the user who is logging in, moving the pam_mount.so entry higher in common-session made pam-mount invoke for both nx user and the user logging in. The nx user fails to authenticate in samba witch is normal but so does the users attempt, witch means pam is forwarding the wrong credentials. Mounting the share manually works fine.

I need some help from anyone who is familiar with how the /etc/pam.d files on 12.04 work, i simply don't understand how they work as a whole so i don't know what im doing. I do however know what i have to realize:
1.Make sure pam forwards the users login password
2.(optional) limit pam-mount to a distinct group(to excluse the nx and root user)

Alternatively, if anyone knows a better way to mount samba shares from a central server at login, id be more then happy to try it since libpam-mount is not maintained anymore witch is the reason for all these issues

vikfreeze 03-04-2013 01:27 PM

i managed to get a bit further, it seems that my hunch was right that pam was forwarding the wrong credentials and it was due to the ssh daemon settings in /etc/sshd_config witch need to look like this:
ChallengeResponseAuthentication no (was changes by lwopen)
PasswordAuthentication yes (this is default)

Now the share mounts at log in but it does not unmount at log out, im not sure if this is a permission or configuration problem(i think i have seen this issue in some forum)

so now the only thing left is if i can configure pam not to invoke for my local user, the nx user and root since this only results in errors because these users don't exist in the active directory, this is not a necessity but it would be nice to have


All times are GMT -5. The time now is 10:58 AM.