LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   pacemaker - how to start a resource (http://www.linuxquestions.org/questions/linux-server-73/pacemaker-how-to-start-a-resource-4175430298/)

eantoranz 10-03-2012 11:35 AM

pacemaker - how to start a resource
 
Hi!

I'm giving pacemaker a test on two ubuntu lucid virtual machines. I have already set up a virtual IP to be shared between them but I can't get the resource to start. At the moment I have heartbeat running on only one of the boxes (ha1):

Code:

$ sudo crm_mon -1
============
Last updated: Wed Oct  3 11:00:28 2012
Stack: Heartbeat
Current DC: ha1 (77ca727a-d965-410c-8829-58449dc0ef89) - partition with quorum
Version: 1.0.8-042548a451fce8400660f6031f4da6f0223dd5dd
2 Nodes configured, unknown expected votes
1 Resources configured.
============

Online: [ ha1 ]
OFFLINE: [ ha2 ]

$ sudo crm_resource --list
 virtual-ip    (ocf::heartbeat:IPaddr) Stopped

What do I have to do to get the virtual ip to come up? Thanks in advance.

Remember, it's ubuntu server 10.04.

eantoranz 10-03-2012 02:33 PM

I have still a lot of ground to cover but at least I have learned a couple of tricks.

Firs, problems in the configuration can be found with this:

Code:

crm_verify -L
That provided this output:
Code:

crm_verify[2129]: 2012/10/03_13:54:43 ERROR: unpack_resources: Resource start-up disabled since no STONITH resources have been defined
crm_verify[2129]: 2012/10/03_13:54:43 ERROR: unpack_resources: Either configure some or disable STONITH with the stonith-enabled option
crm_verify[2129]: 2012/10/03_13:54:43 ERROR: unpack_resources: NOTE: Clusters with shared data need STONITH to ensure data integrity

By reading from http://www.clusterlabs.org/doc/en-US...atch/ch05.html I found that stonith can be disabled with this:
Code:

crm configure property stonith-enabled=false


All times are GMT -5. The time now is 02:03 AM.