LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 10-30-2008, 03:17 AM   #1
jimbo1708
Member
 
Registered: Jan 2007
Location: Pennsylvania
Distribution: Ubuntu 8.10 Server/9.04 Desktop, openSUSE 11.1
Posts: 154

Rep: Reputation: 31
OpenSUSE 11.0: Xen Kernel is not listed in grub


I had an issues a few weeks ago when I had to install windows (for my RAID management software) on a seperate partition after using and existing openSUSE install. The issue was that I had to rewrite the menu.lst file for grub to get the dual boot back up and running.

My issue is that I no longer have my Xen Kernel's listed on there and I don't know how to get them back. I have have verified that the hypervisor and its tools are installed, but how can I get the Xen kernels listed and bootable by grub???

Thanks,
- Jim
 
Old 10-30-2008, 05:56 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You can create an entry for it yourself if you know which kernel and initrd file to use. You can use YaST2 to clone your present entry and then edit the new one. Or do this in a text editor.

Example entry:
Code:
###Don't change this comment - YaST2 identifier: Original name: xen###
title Xen -- openSUSE 11.0 - 2.6.25.18-0.2
    root (hd2,0)
    kernel /xen.gz
    module /vmlinuz-2.6.25.18-0.2-xen root=/dev/system/rootvol resume=/dev/sda2 splash=silent showopts vga=795
    module /initrd-2.6.25.18-0.2-xen
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XEN 3.3 on OpenSuse 10.3 - Waiting for /dev/sda2 to appear Reefcrazed Linux - Software 18 05-07-2010 05:14 AM
Xen CentOS domU / guest on OpenSuSE? jantman Linux - Software 2 01-11-2010 12:01 PM
Lost GRUB bootsplash in openSUSE 11 after changing kernel JamesHall Suse/Novell 7 01-11-2009 06:55 PM
LXer: PV-Grub on OpenSuse 11 PV DomU at Xen 3.3 CentOS Dom0 (all 64-bit) LXer Syndicated Linux News 0 09-23-2008 10:50 AM
how to optimize available memory for xen Server on openSUSE nino_of_qubic Linux - Server 0 05-08-2007 10:30 PM


All times are GMT -5. The time now is 05:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration