LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   openstack - qemu: error running stack.sh (http://www.linuxquestions.org/questions/linux-server-73/openstack-qemu-error-running-stack-sh-4175444832/)

eantoranz 01-09-2013 11:14 AM

openstack - qemu: error running stack.sh
 
Hi!

I want to give openstack a testdrive. I'm running stack.sh on a ubuntu 12.04 server qemu instance. I see some error and it stops (though some processes are still running):

Code:

+ keystone endpoint-create --region RegionOne --service_id --publicurl http://192.168.55.201:5000/v2.0 --adminurl http://192.168.55.201:35357/v2.0 --internalurl http://192.168.55.201:5000/v2.0
usage: keystone endpoint-create [--region <endpoint-region>] --service-id
                                <service-id> [--publicurl <public-url>]
                                [--adminurl <admin-url>]
                                [--internalurl <internal-url>]
keystone endpoint-create: error: argument --service-id/--service_id: expected one argument
++ failed
++ local r=2
+++ jobs -p
++ kill
++ set +o xtrace

Code:

30598 ?        Ss    0:00 SCREEN -d -m -S stack -t shell -s /bin/bash
30602 pts/4    Ss+    0:02  \_ /bin/bash
30771 pts/3    Ss    0:00  \_ /bin/bash
30830 pts/3    S+    0:04      \_ python /opt/stack/keystone/bin/keystone-all --config-file /etc/keystone/keystone.conf --log-config /etc/keystone/logging.conf -d --debug

What am I doing wrong? Thanks in advance.

eantoranz 01-09-2013 01:53 PM

Just noticed I could reenter screen after I had been kicked out and now I see this:

Code:

(keystone-all): 2013-01-09 11:29:50,760 DEBUG cfg log_opt_values ldap.tenant_tree_dn            = None
(keystone-all): 2013-01-09 11:29:50,760 DEBUG cfg log_opt_values ldap.url                      = ldap://localhost
(keystone-all): 2013-01-09 11:29:50,760 DEBUG cfg log_opt_values ldap.use_dumb_member          = False
(keystone-all): 2013-01-09 11:29:50,760 DEBUG cfg log_opt_values ldap.user                      = dc=Manager,dc=example,dc=com
(keystone-all): 2013-01-09 11:29:50,760 DEBUG cfg log_opt_values ldap.user_allow_create        = True
(keystone-all): 2013-01-09 11:29:50,760 DEBUG cfg log_opt_values ldap.user_allow_delete        = True
(keystone-all): 2013-01-09 11:29:50,761 DEBUG cfg log_opt_values ldap.user_allow_update        = True
(keystone-all): 2013-01-09 11:29:50,761 DEBUG cfg log_opt_values ldap.user_attribute_ignore    = tenant_id,tenants
(keystone-all): 2013-01-09 11:29:50,761 DEBUG cfg log_opt_values ldap.user_enabled_attribute    = enabled
(keystone-all): 2013-01-09 11:29:50,761 DEBUG cfg log_opt_values ldap.user_enabled_default      = True
(keystone-all): 2013-01-09 11:29:50,761 DEBUG cfg log_opt_values ldap.user_enabled_mask        = 0
(keystone-all): 2013-01-09 11:29:50,761 DEBUG cfg log_opt_values ldap.user_filter              = None
(keystone-all): 2013-01-09 11:29:50,761 DEBUG cfg log_opt_values ldap.user_id_attribute        = cn
(keystone-all): 2013-01-09 11:29:50,762 DEBUG cfg log_opt_values ldap.user_mail_attribute      = email
(keystone-all): 2013-01-09 11:29:50,762 DEBUG cfg log_opt_values ldap.user_name_attribute      = sn
(keystone-all): 2013-01-09 11:29:50,762 DEBUG cfg log_opt_values ldap.user_objectclass          = inetOrgPerson
(keystone-all): 2013-01-09 11:29:50,762 DEBUG cfg log_opt_values ldap.user_pass_attribute      = userPassword
(keystone-all): 2013-01-09 11:29:50,762 DEBUG cfg log_opt_values ldap.user_tree_dn              = None
(keystone-all): 2013-01-09 11:29:50,762 DEBUG cfg log_opt_values token.driver                  = keystone.token.backends.kvs.Token
(keystone-all): 2013-01-09 11:29:50,763 DEBUG cfg log_opt_values ssl.ca_certs                  = None
(keystone-all): 2013-01-09 11:29:50,763 DEBUG cfg log_opt_values ssl.cert_required              = False
(keystone-all): 2013-01-09 11:29:50,763 DEBUG cfg log_opt_values ssl.certfile                  = None
(keystone-all): 2013-01-09 11:29:50,763 DEBUG cfg log_opt_values ssl.enable                    = False
(keystone-all): 2013-01-09 11:29:50,763 DEBUG cfg log_opt_values ssl.keyfile                    = None
(keystone-all): 2013-01-09 11:29:50,763 DEBUG cfg log_opt_values catalog.driver                = keystone.catalog.backends.sql.Catalog
(keystone-all): 2013-01-09 11:29:50,763 DEBUG cfg log_opt_values ec2.driver                    = keystone.contrib.ec2.backends.sql.Ec2
(keystone-all): 2013-01-09 11:29:50,764 DEBUG cfg log_opt_values sql.connection                = mysql://root:unpassword@localhost/keystone?charset=utf8
(keystone-all): 2013-01-09 11:29:50,764 DEBUG cfg log_opt_values sql.idle_timeout              = 200
(keystone-all): 2013-01-09 11:29:50,764 DEBUG cfg log_opt_values policy.driver                  = keystone.policy.backends.sql.Policy
(keystone-all): 2013-01-09 11:29:50,764 DEBUG cfg log_opt_values pam.password                  = None
(keystone-all): 2013-01-09 11:29:50,764 DEBUG cfg log_opt_values pam.url                        = None
(keystone-all): 2013-01-09 11:29:50,764 DEBUG cfg log_opt_values pam.userid                    = None
(keystone-all): 2013-01-09 11:29:50,765 DEBUG cfg log_opt_values identity.driver                = keystone.identity.backends.sql.Identity
(keystone-all): 2013-01-09 11:29:50,765 DEBUG cfg log_opt_values ********************************************************************************
(eventlet.wsgi.server): 2013-01-09 11:29:57,641 DEBUG wsgi write (30830) wsgi starting up on http://0.0.0.0:35357/

(eventlet.wsgi.server): 2013-01-09 11:29:57,642 DEBUG wsgi write (30830) wsgi starting up on http://0.0.0.0:5000/

/usr/local/lib/python2.7/dist-packages/sqlalchemy/pool.py:703: SADeprecationWarning: The 'listeners' argument to Pool (and create_engine()) is deprecated.  Use event.listen().
  Pool.__init__(self, creator, **kw)
/usr/local/lib/python2.7/dist-packages/sqlalchemy/pool.py:160: SADeprecationWarning: Pool.add_listener is deprecated.  Use event.listen()
  self.add_listener(l)
(eventlet.wsgi.server): 2013-01-09 11:29:58,215 DEBUG wsgi write 192.168.55.201 - - [09/Jan/2013 11:29:58] "GET /v2.0/ HTTP/1.1" 501 264 0.337619

Does it make any sense?

eantoranz 01-09-2013 01:57 PM

When I browse into the server's port 5000 (http://192.168.55.201:5000) I get an error page:

Code:

<?xml version="1.0" encoding="UTF-8"?>
<error xmlns="http://docs.openstack.org/identity/api/v2.0" message="The action you have requested has not been implemented." code="501" title="Not Implemented"/>



All times are GMT -5. The time now is 10:48 PM.