LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 03-07-2011, 12:50 AM   #1
mahao
LQ Newbie
 
Registered: Dec 2010
Posts: 8

Rep: Reputation: 0
Openldap Authentication error 'send_ldap_result: err=49 matched="" text=""'


Our all applications are configured to use OpenLdap as user info repository.

Recently, one user "jirasupport" met some weird problem.

He couldn't login to one application but could login to another applications.

We dont know whats wrong.

So we open debug log of OpenLDAP.

And try to login from those two different application.

The login successfully log is
: do_bind
>>> dnPrettyNormal: <cn=jirasupport,ou=people,ou=eejira,o=nsn>
<<< dnPrettyNormal: <cn=jirasupport,ou=people,ou=eejira,o=nsn>, <cn=jirasupport,ou=people,ou=eejira,o=nsn>
do_bind: version=3 dn="cn=jirasupport,ou=people,ou=eejira,o=nsn" method=128
conn=8 op=0 BIND dn="cn=jirasupport,ou=people,ou=eejira,o=nsn" method=128
==> bdb_bind: dn: cn=jirasupport,ou=people,ou=eejira,o=nsn
bdb_dn2entry("cn=jirasupport,ou=people,ou=eejira,o=nsn")
=> access_allowed: auth access to "cn=jirasupport,ou=People,ou=eejira,o=nsn" "userPassword" requested
=> acl_get: [1] attr userPassword
access_allowed: no res from state (userPassword)
=> acl_mask: access to entry "cn=jirasupport,ou=People,ou=eejira,o=nsn", attr "userPassword" requested
=> acl_mask: to value by "", (=0)
<= check a_dn_pat: cn=manager,ou=eejira,o=nsn
<= check a_dn_pat: *
<= acl_mask: [2] applying read(=rscxd) (stop)
<= acl_mask: [2] mask: read(=rscxd)
=> access_allowed: auth access granted by read(=rscxd)
conn=8 op=0 BIND dn="cn=jirasupport,ou=People,ou=eejira,o=nsn" mech=SIMPLE ssf=0
do_bind: v3 bind: "cn=jirasupport,ou=people,ou=eejira,o=nsn" to "cn=jirasupport,ou=People,ou=eejira,o=nsn"
send_ldap_result: conn=8 op=0 p=3
send_ldap_result: err=0 matched="" text=""
send_ldap_response: msgid=1 tag=97 err=0
conn=8 op=0 RESULT tag=97 err=0 text=



The login failed log is this:
:do_bind
daemon: activity on 1 descriptor
daemon: activity on:
>>> dnPrettyNormal: <cn=jirasupport,ou=people,ou=eejira,o=nsn>
<<< dnPrettyNormal: <cn=jirasupport,ou=people,ou=eejira,o=nsn>, <cn=jirasupport,ou=people,ou=eejira,o=nsn>
do_bind: version=3 dn="cn=jirasupport,ou=people,ou=eejira,o=nsn" method=128
conn=7 op=0 BIND dn="cn=jirasupport,ou=people,ou=eejira,o=nsn" method=128

==> bdb_bind: dn: cn=jirasupport,ou=people,ou=eejira,o=nsn
bdb_dn2entry("cn=jirasupport,ou=people,ou=eejira,o=nsn")
daemon: epoll: listen=7 active_threads=0 tvp=NULL
=> access_allowed: auth access to "cn=jirasupport,ou=People,ou=eejira,o=nsn" "userPassword" requested
daemon: epoll: listen=8 active_threads=0 tvp=NULL
=> acl_get: [1] attr userPassword
access_allowed: no res from state (userPassword)
=> acl_mask: access to entry "cn=jirasupport,ou=People,ou=eejira,o=nsn", attr "userPassword" requested
=> acl_mask: to value by "", (=0)
<= check a_dn_pat: cn=manager,ou=eejira,o=nsn
<= check a_dn_pat: *
<= acl_mask: [2] applying read(=rscxd) (stop)
<= acl_mask: [2] mask: read(=rscxd)
=> access_allowed: auth access granted by read(=rscxd)
send_ldap_result: conn=7 op=0 p=3
send_ldap_result: err=49 matched="" text=""
send_ldap_response: msgid=1 tag=97 err=49
conn=7 op=0 RESULT tag=97 err=49 text=
daemon: activity on 1 descriptor
daemon: activity on:
20r

daemon: read active on 20
daemon: epoll: listen=7 active_threads=0 tvp=NULL
daemon: epoll: listen=8 active_threads=0 tvp=NULL
connection_get(20)
connection_get(20): got connid=7
connection_read(20): checking for input on id=7
ber_get_next on fd 20 failed errno=0 (Success)
connection_read(20): input error=-2 id=7, closing.
connection_closing: readying conn=7 sd=20 for close
connection_close: conn=7 sd=-1
daemon: removing 20
conn=7 fd=20 closed (connection lost)



We compare their difference and found:

conn=8 op=0 BIND dn="cn=jirasupport,ou=People,ou=eejira,o=nsn" mech=SIMPLE ssf=0
do_bind: v3 bind: "cn=jirasupport,ou=people,ou=eejira,o=nsn" to "cn=jirasupport,ou=People,ou=eejira,o=nsn"


This line not present in failed log.

And we dont know why same user login different application would bring this error.

Please any body know about this, help us.

Thanks a lot.
 
Old 03-07-2011, 12:56 AM   #2
mahao
LQ Newbie
 
Registered: Dec 2010
Posts: 8

Original Poster
Rep: Reputation: 0
And this is the record of 256 loglevel.

faild log:

Mar 7 08:54:07 esjirt68 slapd[14332]: conn=0 op=97136 SRCH base="ou=People,ou=eejira,o=nsn" scope=2 deref=3 filter="(&(objectClass=inetOrgPerson)(cn=jirasupport))"
Mar 7 08:54:07 esjirt68 slapd[14332]: conn=0 op=97136 SEARCH RESULT tag=101 err=0 nentries=1 text=
Mar 7 08:54:07 esjirt68 slapd[14332]: conn=28 fd=21 ACCEPT from IP=127.0.0.1:33776 (IP=0.0.0.0:389)
Mar 7 08:54:07 esjirt68 slapd[14332]: conn=28 op=0 BIND dn="cn=jirasupport,ou=people,ou=eejira,o=nsn" method=128
Mar 7 08:54:07 esjirt68 slapd[14332]: conn=28 op=0 RESULT tag=97 err=49 text=
Mar 7 08:54:07 esjirt68 slapd[14332]: conn=28 fd=21 closed (connection lost)


successful log:

Mar 7 08:55:58 esjirt68 slapd[14332]: conn=0 op=97137 SRCH base="ou=People,ou=eejira,o=nsn" scope=2 deref=3 filter="(&(objectClass=inetOrgPerson)(cn=jirasupport))"
Mar 7 08:55:58 esjirt68 slapd[14332]: conn=0 op=97137 SEARCH RESULT tag=101 err=0 nentries=1 text=
Mar 7 08:55:58 esjirt68 slapd[14332]: conn=29 fd=21 ACCEPT from IP=127.0.0.1:33789 (IP=0.0.0.0:389)
Mar 7 08:55:58 esjirt68 slapd[14332]: conn=29 op=0 BIND dn="cn=jirasupport,ou=people,ou=eejira,o=nsn" method=128
Mar 7 08:55:58 esjirt68 slapd[14332]: conn=29 op=0 BIND dn="cn=jirasupport,ou=People,ou=eejira,o=nsn" mech=SIMPLE ssf=0
Mar 7 08:55:58 esjirt68 slapd[14332]: conn=29 op=0 RESULT tag=97 err=0 text=
 
  


Reply

Tags
authentication, openldap


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xend.err "Error creating domain: Boot loader didn't return any data!" mhgee Linux - Virtualization and Cloud 1 10-15-2009 02:50 AM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 07:11 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 08:31 AM
"mythtv-setup" giving "Session management error: Authentication Rejected" Mitchua Ubuntu 0 10-09-2005 04:32 PM


All times are GMT -5. The time now is 04:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration