LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   On boot the fsck of 2TB file-system fails (http://www.linuxquestions.org/questions/linux-server-73/on-boot-the-fsck-of-2tb-file-system-fails-800190/)

thllgo 04-05-2010 04:24 PM

On boot the fsck of 2TB file-system fails
 
Hello

Question: I have a 2TB file-system and when the machine reboots it fails the fsck, halts and goes into maintenance mode.

Stats: I have have RHEL 5, 2.6.18 kernel, the file-system is an ext3. The file-system is on an EMC AX4 connected with fiber channel HBA.

So far my reading tells me this should work because under 2.6 4TB is OK. Any ideas why this fails?

If I take it out of the fstab file and mount it manually the boot is OK and the file-system behaves well. I can change the fsck check option in the fstab to 0 but I don't think I should have too. Everything I read says that 2TB ext3 file-systems are OK.

paulsm4 04-05-2010 04:43 PM

Q: Are you using e2fsck?

Q: What is the exact error message?

Q: Any other relevant info you can provide?

TIA .. PSM

thllgo 04-05-2010 05:31 PM

Quote:

Originally Posted by paulsm4 (Post 3925290)
Q: Are you using e2fsck?

I don't really know, I would guess so. Its being run by the OS on boot.

Quote:

Originally Posted by paulsm4 (Post 3925290)
Q: What is the exact error message?

Could not fsck the file system. fsck must be run manually.

Quote:

Originally Posted by paulsm4 (Post 3925290)
Q: Any other relevant info you can provide?

I have not run the command by hand. As soon as the system boots we have the database startup and it uses the partition so you can't unmount it. You can't fsck a mounted partition. When our database guy comes in in the morning I will have him stop the database and I will do a manual fsck and see what happens.

thllgo 04-07-2010 04:27 PM

I was finally able to do a manual fsck of the file-system, it didn't have a problem.

jhollinger 02-16-2011 02:21 PM

Just ran into the same problem. Dropped me to maintenance mode. Did you every find the problem?

thllgo 02-16-2011 06:46 PM

I've yet to determine why this happens. I finally had to set the fsck options in /etc/fstab to 0 0 like an nfs partition so the system wouldn't do a check.


All times are GMT -5. The time now is 09:03 PM.