LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   no package 'OpenSSL ' found [CentOS] (http://www.linuxquestions.org/questions/linux-server-73/no-package-openssl-found-%5Bcentos%5D-4175413328/)

amanacare 06-25-2012 05:09 PM

no package 'OpenSSL ' found [CentOS]
 
hello,

I have CentOS and i have ran the command yum install openssl and it showed me that its installed and latest version! but I keep getting this message:

Code:

configure: error: Package requirements (openssl) were not met:

No package 'openssl' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables OPENSSL_CFLAGS
and OPENSSL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


how can i fix this please?
I'm really desperate :(

Kustom42 06-25-2012 07:21 PM

You should have your openssl libraries at /usr/lib/openssl/engines/ does that directory exist with .so's inside of it?

unSpawn 06-25-2012 08:40 PM

This isn't about the openssl package: the OP needs to install the openssl-devel package.

amanacare 06-26-2012 04:09 AM

I have openssl-devel installed too, that's what makes my head spin! :/
I have ran:
yum install openssl
yum install openssl*
yum install openssl-devel

but same problem above when dealing with libtorrent!
if you wish I can give you access to the server, you are a Moderator and clearly very trusted :)

amanacare 06-26-2012 04:20 AM

Quote:

Originally Posted by Kustom42 (Post 4711753)
You should have your openssl libraries at /usr/lib/openssl/engines/ does that directory exist with .so's inside of it?

yes it does exist with .so inside it


All times are GMT -5. The time now is 11:33 PM.