LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   NFS over SSH (http://www.linuxquestions.org/questions/linux-server-73/nfs-over-ssh-790754/)

Mr Pink 02-22-2010 07:23 AM

NFS over SSH
 
Hi,

I am not sure what I am doing but I followed this http://www.howtoforge.com/nfs_ssh_tunneling

and when I try and mount it manually I get

root@client:~# mount localhost:/test /home/www-data/test/ -o rw,tcp,port=62000,mountport=62001
mount.nfs: internal error

The server

root@gp-wpbalance:/test# rpcinfo -p
program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 32947 status
100024 1 tcp 32798 status
100003 2 udp 2049 nfs
100003 3 udp 2049 nfs
100003 4 udp 2049 nfs
100021 1 udp 2232 nlockmgr
100021 3 udp 2232 nlockmgr
100021 4 udp 2232 nlockmgr
100021 1 tcp 2232 nlockmgr
100021 3 tcp 2232 nlockmgr
100021 4 tcp 2232 nlockmgr
100003 2 tcp 2049 nfs
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
100005 1 udp 2233 mountd
100005 1 tcp 2233 mountd
100005 2 udp 2233 mountd
100005 2 tcp 2233 mountd
100005 3 udp 2233 mountd
100005 3 tcp 2233 mountd

My tunnels on the client

www-data 23303 1 0 12:30 ? 00:00:00 /usr/lib/autossh/autossh -M 5001 sleeper@gp-wpbalance -NL 62000:server:2049
www-data 23308 1 0 12:30 ? 00:00:00 /usr/lib/autossh/autossh -M 5002 sleeper@gp-wpbalance -NL 62001:server:2233

I can telnet to both the listening ports and I can also mount NFS normally from the other server.

In my Syslog on the client I see this

Feb 22 13:19:52 client kernel: [935640.770093] mount: server localhost not responding, timed out


I think its not using the correct ports on the client side but I am not sure? Does anyone have any suggestions?

Thanks,
Will

MensaWater 02-22-2010 10:37 AM

This talks about /etc/default/nfs-common which is what sets the ports for Debian. It also talks about firewall settings to insure the ports are opened.

http://wiki.debian.org/SecuringNFS


All times are GMT -5. The time now is 05:25 PM.