LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-17-2009, 11:54 PM   #1
pug2694328
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Rep: Reputation: 0
nfs client problem


I have an ubuntu server 6.06 with nfs share setup on a particular folder for any computers in my local network. I have no problems mounting the share in one of my ubuntu 8 client machines, but when I try the exact same mount in my other machine I get interminable clocking. The client /var/log/messages shows this message:

nfs:server 192.168.1.5 not responding, still trying

That's the correct static ip of my server. I can ping it with a strong connection from the client computer.

Any help would be greatly appreciated.
 
Old 01-18-2009, 05:00 PM   #2
lurko
Member
 
Registered: Jun 2006
Location: Ontario, Canada
Distribution: Debian
Posts: 448

Rep: Reputation: 35
The obvious things to look at are /etc/exports and /etc/hosts.deny on the server, and /etc/hosts on both server and client. Some part of the setup probably says that your other machine isn't allowed to connect.
 
Old 01-18-2009, 06:36 PM   #3
pug2694328
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by lurko View Post
The obvious things to look at are /etc/exports and /etc/hosts.deny on the server, and /etc/hosts on both server and client. Some part of the setup probably says that your other machine isn't allowed to connect.
Thanks, yes I should have provided those values. Maybe something's amiss:

The client ip address of the pc that is problematic is 192.168.1.107
The client /etc/hosts on the pc that is problematic is:
127.0.0.1 localhost
127.0.1.1 problemclientusername-computername
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhost

The client ip address of the pc that is able to mount the share is 192.168.1.100
The client /etc/hosts on the pc that is able to mount the share is:
127.0.0.1 localhost
127.0.1.1 goodclientusername-computername
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

The server /etc/hosts.deny has the following settings:
portmap:ALL
lockd:ALL
mountd:ALL
rquotad:ALL
statd:ALL

The server /etc/hosts.allow has the following settings:
portmap:ALL
lockd:ALL
mountd:ALL
rquotad:ALL
statd:ALL

The server has a static ip of 192.168.1.5

The server /etc/hosts has the following settings:
127.0.0.1 localhost
127.0.1.1 servercomputername

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

The server /etc/exports has the following rows:
/ 192.168.1.0/255.255.255.0(rw)
/home/someuserid 192.168.1.0/255.255.255.0(rw)
/export 192.168.1.99/255.255.255.0(rw,fsid=0)

The mount command I'm using on both clients is:
sudo mount -o intr 192.168.1.5:/home/someuserid /home/someuserid/Desktop/server

When I try to umount the share that's clocking incessantly on the client I get these error rows (yes twice):
umount.nfs: /home/someuserid/Desktop/server: device is busy
umount.nfs: /home/someuserid/Desktop/server: device is busy

I have to reboot the client pc to get the mount point back to being just an empty folder on the client desktop.

Is there something in the nfs files that looks like it would deny access to the server share?
 
Old 01-18-2009, 11:55 PM   #4
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,289

Rep: Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034
It doesn't make sense to duplicate the entries in the hosts.allow and hosts.deny, see http://itso.iu.edu/TCP_Wrappers
 
Old 01-19-2009, 07:57 AM   #5
pug2694328
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Original Poster
Rep: Reputation: 0
/etc/hosts.deny updated

Quote:
Originally Posted by chrism01 View Post
It doesn't make sense to duplicate the entries in the hosts.allow and hosts.deny, see http://itso.iu.edu/TCP_Wrappers
Thanks I've changed the hosts.deny to have just the one row ALL:ALL
This doesn't have any effect on the client nfs problem of course but reading that article was very helpful!

Any thoughts on what might be causing the server/client issue?
 
Old 01-19-2009, 07:49 PM   #6
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,289

Rep: Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034
How about extending the timeout option on the client (http://www.linuxtopia.org/online_boo...nt-config.html). http://fixunix.com/nfs/61856-kernel-...ll-trying.html mentions that and other things such as retrans and forcing TCP instead of udp.

Also, BTW, if you want alternate names for the localhost, they go on the same line, not as a different IP

eg


127.0.0.1 localhost servercomputername

instead of

127.0.0.1 localhost
127.0.1.1 servercomputername
 
Old 01-23-2009, 11:05 AM   #7
chitambira
Member
 
Registered: Oct 2008
Location: Fife
Distribution: RHEL, Centos
Posts: 373
Blog Entries: 1

Rep: Reputation: 49
Remove everything in both /etc/hosts.deny and /etc/hosts.allow!!!
The other thing is, what is the network structure like, from the working client to the server and from the problematic client to the server? If there are routers somewhere, it might be a worthwhile figuring the acls on the path of the problematic client (assuming these two clients are connecting from different segments)

I supposes you alredy have the /home/someuserid/Desktop/server directory created and that the root has access to it (permissions)

Before you do much troubleshooting, what happens when you follow the simple steps from problem client:
-ping server (shld be ok as u said earlier)
-if ok, telnet server on nfs port
-if ok, check the firewall of the client (if any)
-if ok, try #mount -t nfs -o intr 192.168.1.5:/home/someuserid /home/someuserid/Desktop/server
 
  


Reply

Tags
nfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nfs server on ubuntu doesn't play nice with nfs client on solaris mathiraj Linux - Networking 11 09-15-2009 02:08 PM
Unusual NFS mount problem on only ONE client: Red Hat WS Rel 3 neelpert1 Linux - Networking 0 01-16-2009 12:13 PM
NFS error: sometimes unable to find the files at NFS-client machines samengr Linux - Server 0 09-01-2008 11:26 AM
NFS client = Linux, NFS server = Mac OS X Tiger --> Hell of a problem make Linux - Networking 9 03-10-2006 05:16 AM
nfs client on knoppix 3.9 - problem mounting nfs drive Rod Butcher Linux - Networking 1 09-21-2005 04:18 AM


All times are GMT -5. The time now is 02:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration