LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-07-2006, 06:26 PM   #1
phobus
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Rep: Reputation: 0
Unhappy need help with bind!! help much appreciated


details:im currently working on a school project that includes dns(bind), the goal is to setup bind on redhat 9.0.
i am an mcsa so im fairly attuned to how dns functions.

ive setup bind to the best of my knowledge and as far as im concerned i should be getting ping replies from my domain but im not.

goal: to receive a ping reply from technowidgets.com

eth0 config: 192.168.0.100 netmask /24

files:named.custom
Code:
## named.custom - custom configuration for bind
#
# Any changes not currently supported by redhat-config-bind should be put 
# in this file.
#


zone  "technowidgets.com" IN {
       type master;
       file  "named.technowidgets.com";
};

zone  "0.168.192.in-addr.arpa" IN {
       type master;
       file  "named.0.168.192";
};


options {
       directory "/var/named/";
};
files:named.0.168.192
Code:
$TTL 86400
@       IN      SOA     web1.technowidgets.com. admn.technowidgets.com. (
               2002072100;Serial
               28800     ;Refresh
               14400     ;Retry
               3600000   ;Expire
               86400)    ;Minimum
       IN      NS      web1

50      IN      PTR     web2.technowidgets.com.
100     IN      PTR     web1.technowidgets.com.
150     IN      PTR     intranet.technowidgets.com.
200     IN      PTR     research.technowidgets.com.
files:named.technowidgets.com
Code:
$TTL 86400
@ IN SOA web1.technowidgets.com. admn.technowidgets.com. (
               2002072100;Serial
               28800     ;Refresh
               14400     ;Retry
               3600000   ;Expire
               86400)    ;Minimum

IN      NS      web1
       IN      A       192.168.0.100
       IN      MX 10 mail.technowidgets.com.

web2            IN      A       192.168.0.50
web1            IN      A       192.168.0.100
www             IN      CNAME   web1
mail            IN      CNAME   web1
intranet        IN      A       192.168.0.150
research        IN      A       192.168.0.200
files:resolv.conf
Code:
; generated by /sbin/dhclient-script
nameserver 192.168.0.100
nameserver 192.168.0.50
nameserver 192.168.0.150
nameserver 192.168.0.200

domain technowidgets.com

for some reason my named.conf file isnt in the /etc directory just my named.custom file. do i need to create the default named.conf file?

im trying to ping/dig the domain locally so i dont need to worry about firewalls etc... i can ping 192.168.0.100 which is my local address.

thanks
phobus
 
Old 11-07-2006, 06:40 PM   #2
phobus
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
added named.conf

i went ahead and created a named.conf file in /etc

file:/etc/named.conf

Code:
## named.conf - configuration for bind
#
# Generated automatically by redhat-config-bind, alchemist et al.
# Any changes not supported by redhat-config-bind should be put
# in /etc/named.custom
#
controls {
       inet 127.0.0.1 allow { localhost; } keys { rndckey; };
};

include "/etc/named.custom";

include "/etc/rndc.key";







zone  "0.0.127.in-addr.arpa" {
       type master;
       file  "0.0.127.in-addr.arpa.zone";
};


zone  "localhost" {
       type master;
       file  "localhost.zone";
};

still doesnt work

i also ran /usr/sbin/
./named-checkconf

didnt return anything(which i guess is good)
 
Old 11-08-2006, 02:02 AM   #3
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,885

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
First of all you need an "options" section in your /etc/named.conf that among other things contains a "directroy .." statement that points to the directory where your zone files (named.0.168.192, named.technowidgets.com) are located, e.g.
Code:
directory "/var/named";
Then make sure that bind is running and watch for resolve errors in your log files. You should take a look at bind howto to see what other things you may need to specify in your named.conf.

Regards
 
Old 11-08-2006, 02:21 AM   #4
phobus
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory
First of all you need an "options" section in your /etc/named.conf that among other things contains a "directroy .." statement that points to the directory where your zone files (named.0.168.192, named.technowidgets.com) are located, e.g.
Code:
directory "/var/named";
Then make sure that bind is running and watch for resolve errors in your log files. You should take a look at bind howto to see what other things you may need to specify in your named.conf.

Regards

the portion that refers to my /var/named directory is stored in the /etc/named.custom file. i wasnt the one that placed it there, redhat 9 uses a custom file and it placed it there. as far as i know as long aas it reads the files line by line it should still parse the info.

as far as bind running ive killed and restarted named i dont know how many times. i even use pkill named due to redhat 9's innability to cleanly kill named.

ive mainly refferred to the redhat 9.0's manual on bind as far as configuration goes due to the differences ive seen.


thanks for replying although i think im in need of a little more info to get this resolved.

thanks again
phobus
 
Old 11-08-2006, 03:04 AM   #5
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,885

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Can you ping/resolv other hosts in your network? If yes but you cannot ping/resolv your domain, then edit the following line in named.technowidgets.com
Quote:
IN A 192.168.0.100
to:
Code:
@       IN      A       192.168.0.100
increase the serial and restart bind or reload the zone.
 
Old 11-08-2006, 05:04 PM   #6
phobus
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
still not working, i cant ping hosts via name on my domain yet i can ping them directly via ip.

heres what i get when i run dig/nslookup

dig:

Code:
[root@localhost root]# dig technowidgets.com
 
; <<>> DiG 9.2.1 <<>> technowidgets.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 53943
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
 
;; QUESTION SECTION:
;technowidgets.com.             IN      A
 
;; Query time: 60 msec
;; SERVER: 192.168.0.100#53(192.168.0.100)
;; WHEN: Tue Nov  7 09:22:26 2006
;; MSG SIZE  rcvd: 35

NSLOOKUP:
Code:
[root@localhost root]# nslookup technowidgets.com
Note:  nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead.  Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
Server:         192.168.0.100
Address:        192.168.0.100#53
 
** server can't find technowidgets.com: SERVFAIL

thought it might be my resolv.conf heres what it looks like:
Code:
; generated by /sbin/dhclient-script
nameserver 192.168.0.100
nameserver 192.168.0.50
nameserver 192.168.0.150
nameserver 192.168.0.200

domain technowidgets.com

thanks for the help, hope i can get this working.
ide be interested in finding a good troubleshooting guide most of the guides ive read were insufficient for redhat 9.
 
Old 11-09-2006, 02:07 AM   #7
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,885

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Since your dns does not know anything about technowidgets.com, I guess that the file named.custom that is used to define the zone "technowidgets.com" is not read. I suggest you to copy the contents of named.custom in named.conf and see what happens.
Note also that in redhat's bind manual there is nothing about that named.custom. Perhaps it's a file that is used as a template to create your named.conf
 
  


Reply

Tags
bind, configuration, redhat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: DNS: The Bind Leading the Bind LXer Syndicated Linux News 0 06-15-2006 10:33 PM
Help Appreciated delius343 Slackware - Installation 7 05-19-2006 11:18 PM
10.1 installation (Help Appreciated) ObsidianOP Mandriva 3 06-11-2005 09:23 PM
Help appreciated with Xine Installation ! =) Pseudonym88 Fedora 2 06-23-2004 05:22 PM
Any help appreciated karnevil9 Linux From Scratch 5 01-06-2004 11:28 PM


All times are GMT -5. The time now is 03:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration