LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 04-03-2008, 05:58 PM   #1
Dark Jirachi
LQ Newbie
 
Registered: Jul 2007
Distribution: OpenSUSE
Posts: 16

Rep: Reputation: 0
Need help getting Windows Vista to see my Linux machine running Samba


Alright, I have a Linux machine running OpenSUSE, and another machine running Windows Vista Home Basic, both of them are connected to my modem via a network hub. I can get both of them on the internet just fine, but I'd like to be able to see the Linux machine in my Windows network. OpenSUSE comes with Samba, but I can't seem to get it configured right, and no matter how many different tutorials I follow, Windows will not see my Linux box. I don't know what to do.
 
Old 04-03-2008, 06:35 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Run the firewall setup program in YaST2 and make sure that the samba ports are open.
Also make sure that both computers use the same WORKGROUP.
See if you can ping back and forth.
Make sure both computers are on the same subnet. ( e.g. 192.168.1.xxx ).

Post the [global] and the share definition of your /etc/samba/smb.conf file. Put them in [ code ] blocks to make it easier to read.

Make sure that filesharing is enabled in Vista. Also check Vista's firewall setting as well.

Part of the problem could be using an old version of Samba. If you aren't using openSUSE 10.3, consider upgrading. MS intentionally tried to "f#$k with samba". (Source: Jeremy Elleson, who was told of a memo by an MS programmer.)

Last edited by jschiwal; 04-03-2008 at 06:40 PM.
 
Old 04-04-2008, 10:35 PM   #3
Dark Jirachi
LQ Newbie
 
Registered: Jul 2007
Distribution: OpenSUSE
Posts: 16

Original Poster
Rep: Reputation: 0
I finally found a tutorial that actually worked. I am able to get the computers to see each other. But when I try and access Windows from Linux it asks for a user name and password. When I try and access Linux from Windows, it shows up in the network, but if I try and access it I get an error saying that //LINUXBOX (what I named it) does not exist, yet it still shows up as being in my network.

I'm not sure which ports samba uses, so I don't know what to open.

Both computers are in the same workgroup.

I've never pinged anything before, but if I try and ping the IP of my Windows machine, nothing seems to happen at all.

I don't know how to tell what my IP or subnet and that kind of thing is from Linux (I'm kind of a newbie), so I don't know about that. I am fairly certain that they are though.

Here's my smb.conf:
Code:
# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2008/04/03 17:37:59

[global]
	netbios name = LINUXBOX
	guest account = pcguest
	os level = 2
	preferred master = No
	local master = No
	domain master = No
	hosts allow = 192.168.0.0/255.255.255.0

[dj]
	path = /home/darkjirachi/share
	read only = No
	guest ok = Yes
	available = Yes
File sharing is enabled, but again I don't know what ports to open in the firewall.

I am using openSUSE 10.3.

I can ping the Linux machine from Windows and get a response, but I cannot access it from the network.

Last edited by Dark Jirachi; 04-04-2008 at 10:55 PM.
 
Old 04-05-2008, 06:45 AM   #4
ZeroCool42
LQ Newbie
 
Registered: Dec 2007
Posts: 4

Rep: Reputation: 0
While I'm afraid I know relatively little about the subject at hand, I feel obliged to try and lend a hand, so apologies in advance if I hinder rather than help.

First of all, I must agree with jschiwal, have you tried upgrading to the latest version of samba (if you don't have it already), I say this because I set up a bunch of samba shares recently, in my usual way, and have had no problem connecting to them with a friend's vista laptop (they do take AAAAGES to show up in the vista networking window tho).

Secondly, the hosts allow = 192.168.0.0/255.255.255.0 line intrigues me, have you tried commenting, removing this line. I'm afraid I haven't a clue if this will help, but its got to be worth a try.

If nothing else, know this, its definetly possible, you've just got to keep trying

PS. I will try and post the tutorial I used to setup my samba shares if I find it!
 
Old 04-06-2008, 05:57 AM   #5
Lord Matt
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Rep: Reputation: 0
Like ZeroCool42 I'm not an expert in such matters but I have had a heck of a time getting a vista laptop that Toshiba gave me (I was a very happy boy about that) to talk to my network. Vista does not play nicely with other systems (not even windows ones) on a network. If you play with the settings it will start to scream about insecure this that and the other and warn you about "public" this and so forth (forgive me I can not remember the exact details).

I found a lot of very helpful tutorials when I Googled variants of "network vista and XP". It seems that the Windows world is trying to get Vista networked and having a hard time too so it's not just you. You may be as well to look at some of these xp-vista tutorials and make sure that the vista device is singing from the right hymn book. That at least will eliminate a bunch of potential issues.

Hope that helps.
 
Old 04-06-2008, 06:47 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
By the way, which openSuSE distro are you using. I guess that you need 10.3 to be able to network with Vista.
If you have SuSE 10.3 and samba-3.0.26a-3.5 then the samba version isn't the problem.
Also try to enable one or more of these ports in SuSE's firewall:
Code:
Samba
    135/TCP: epmap [DCE endpoint resolution]
    137/UDP: netbios-ns [NETBIOS Name Service]
    138/UDP: netbios-dgm [NETBIOS Datagram Service]
    139/TCP: netbios-ssn [NETBIOS Session Service]
    445/TCP: microsoft-ds [Microsoft-DS]
This link may help as well:
http://www.swerdna.net.au/linhowtosambasecure.html

Last edited by jschiwal; 04-06-2008 at 06:52 AM.
 
Old 05-10-2008, 12:51 AM   #7
sikandar436
LQ Newbie
 
Registered: Oct 2007
Location: Huddersfield UK
Distribution: FC5, FC7, and centOS5
Posts: 11

Rep: Reputation: 0
I was having the same problem and allmost the same scenario.

Solution: Vista comes with an AntiVirus (Norton) right! (Thats what my Toshiba Satelite came with). I went to the Norton settings and opened Inbound NetBios ports from there and a couple of other related ports and the things worked for me..

Remember: Learning new things involve a lot of practices and try again and again... so give a try to every possible solution that comes in the way...

Best of luck

Sikandar
 
Old 05-12-2008, 02:59 PM   #8
G4george
Member
 
Registered: Nov 2005
Location: Houston, Tx
Posts: 34

Rep: Reputation: 15
Ok. In smb.conf for each share you need "valid user = username"
you will need to do a "smbpasswd -a username" and give password.
This is the username / passwork Windows is asking for.

If installed try using "swat" to configure samba.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows Can't See Linux Machine After Configuring Samba! movanns Linux - Networking 6 02-13-2014 02:52 AM
Problems selecting and running Windows Vista from Grub menu in Suse Linux 10.2 mrukjames Suse/Novell 4 03-09-2008 09:09 AM
running programs on a windows machine from linux thesnaggle Linux - Networking 7 05-07-2004 02:44 PM
Can't see linux box running Samba from Windows machine RBLynch Linux - Newbie 2 03-21-2002 08:59 PM


All times are GMT -5. The time now is 04:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration