LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 08-02-2008, 02:47 AM   #1
algogeek
Member
 
Registered: Apr 2008
Distribution: Fedora 9, Ubuntu 8.04, Ubuntu 8.04 Server
Posts: 103

Rep: Reputation: 15
named does not listen on eth0 right after boot.


Hi friends,

This is a weird problem I'm pitted against on my Fedora 9 server which I would like to have as a local dns caching server on my network.

What happens is that right after reboot, named refuses to listen on the ethernet interface. I have to do /etc/init.d/named restart to read the named.conf file again and begin working.

I came to know this through this log entry (showing the named restart cycle)

Code:
Aug  2 12:58:25 india named[2165]: received control channel command 'stop'
Aug  2 12:58:25 india named[2165]: shutting down: flushing changes
Aug  2 12:58:25 india named[2165]: stopping command channel on 127.0.0.1#953
Aug  2 12:58:25 india named[2165]: stopping command channel on ::1#953
Aug  2 12:58:25 india named[2165]: no longer listening on ::1#53
Aug  2 12:58:25 india named[2165]: no longer listening on 127.0.0.1#53
Aug  2 12:58:25 india named[2165]: exiting
Aug  2 12:58:28 india named[4122]: starting BIND 9.5.0-P1 -u named -t /var/named/chroot
Aug  2 12:58:28 india named[4122]: found 2 CPUs, using 2 worker threads
Aug  2 12:58:28 india named[4122]: loading configuration from '/etc/named.conf'
Aug  2 12:58:28 india named[4122]: the working directory is not writable
Aug  2 12:58:28 india named[4122]: listening on IPv6 interface lo, ::1#53
Aug  2 12:58:28 india named[4122]: listening on IPv4 interface lo, 127.0.0.1#53
Aug  2 12:58:28 india named[4122]: listening on IPv4 interface eth0, 192.168.1.6#53
The log file also contains many entries showing:
Code:
Aug  2 12:47:01 india named[2165]: too many timeouts resolving '1.fedora.pool.ntp.org/A' (in '.'?): disabling EDNS
which I cannot understand, but would like to get rid of.

My firewall ports are open, and things work well right after a named restart, but I certainly wouldn't like doing it after each reboot of the server.

Can anyone tell me what the problem is? Is it a bug in named?

I had added this entry to the named.conf file to listen on the ethernet interface:
Code:
	listen-on port 53 { 127.0.0.1; 192.168.1.6; };
	listen-on-v6 port 53 { ::1; };
 
Old 08-02-2008, 02:57 AM   #2
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Have you verified that the interface is actually up and working at the point named starts?

To eliminate the edns timeouts, add:

Code:
logging {
     ...
     category edns-disabled { null; };
     ...
}
to named.conf.

Last edited by Mr. C.; 08-02-2008 at 02:58 AM.
 
Old 08-02-2008, 10:25 AM   #3
algogeek
Member
 
Registered: Apr 2008
Distribution: Fedora 9, Ubuntu 8.04, Ubuntu 8.04 Server
Posts: 103

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Mr. C. View Post
Have you verified that the interface is actually up and working at the point named starts?

To eliminate the edns timeouts, add:

Code:
logging {
     ...
     category edns-disabled { null; };
     ...
}
to named.conf.
Thanks, I added that part to named.conf, and restarted named. I am yet to see the results, but it seems like its working. Thanks a ton.

About the listening issue, that is something that had also occurred to me, but I didn't know how to do it. Some pointers please.

Last edited by algogeek; 08-02-2008 at 10:26 AM.
 
Old 08-02-2008, 11:54 AM   #4
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
You can test the theory by adding a line to the /etc/rc.d/named script that shows the output of ifconfig -a. Add the line:

ifconfig -a > /tmp/testing.out

somewhere near the top. Then either reboot, or bring the system down to run level 1 and back up to either 3 or 5 as is normal for you (stated in /etc/inittab). Check the contents of /tmp/testing.out. Either eth0 will exist and be up, or not.

If eth0 is not up, look in /var/log/messages and /var/log/dmesg for clues as to eth0.

It is possible it is coming up slowly, and/or named is started before the interface is fully ready.

The scripts in /etc/init.d are run in numeric order. I don't recall what scripts exist in Fedora. If there is a named or bind startup/stop script, determine its number and determine where it is relative to the script that starts up networking.

If this isn't clear, show output of :

ls -ld /etc/rc2.d/* /etc/rc3.d/*

Your goal is to
 
Old 09-04-2008, 02:08 PM   #5
Chobel
LQ Newbie
 
Registered: Sep 2008
Location: Mexico
Distribution: FC9
Posts: 1

Rep: Reputation: 0
I had the same problem, and the way I fixed it is as follows

Using system-config-services:

1. Disable "Network Manager" from the list of services at boot-up time
2. Enable "network"

Using system-config-network:

1. Uncheck the "Controlled by NetworkManager" from the Device (in my case eth0)

Reboot the machine and presto!

I don't have a good explanation, but I think if Bind is started before the computer acquires an IP address (by Network Manager) then it won't Listen on the IP address that doesn't know at that time.
 
  


Reply

Tags
bind, dns, fedora, fedora 9, firewall, listen, named


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
named to start at boot dody1313 Solaris / OpenSolaris 6 06-01-2008 07:19 AM
starting named at boot dody1313 Linux - Server 3 05-30-2008 12:14 PM
FC4 System Crash bcs chown -R named:named extend joangopan Fedora 1 09-09-2007 02:46 AM
chown -R named:named /var/named crash the system? joangopan Fedora 2 09-09-2007 02:46 AM
named Starts at Boot Even When Disabled? sancho Fedora 4 09-15-2006 12:48 PM


All times are GMT -5. The time now is 01:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration