LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-06-2007, 08:48 PM   #1
hondo
Member
 
Registered: Jul 2005
Location: norway
Posts: 198

Rep: Reputation: 33
Nagios not starting up properly


Im having some problems with Nagios. Ive set up this program and configured it in a very small way, like adding one host and a service. I then verified the config file for Nagios which went well without any errors or warnings.

When i access nagios from the net it works fine, but when im trying to access a page in nagios i get this message:
Code:
"Error: Could not read host and service status information!"
On the page it says that this usually is because nagios isnt started properly or correcly. I have read the docs on how to start/reload/verify the configuration for nagios and im still getting this message.

Does someone know why im getting this message and how i can correct it? I appericiate all help

Additional information:

When im in nagios and viewing the log files i get these messages:
Code:
[04-07-2007 02:51:34] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:43:17] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:41:34] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:33:17] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:33:17] Error: Could not connect to MySQL database '' on host '' using username '' and password 'XXXXXX'. Retention data will not be processed or saved!
[04-07-2007 02:31:34] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:31:04] Error: Could not connect to MySQL database '' on host '' using username '' and password 'XXXXXX'. Retention data will not be processed or saved!
[04-07-2007 02:23:17] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:21:34] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:13:17] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:11:34] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:03:17] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...
[04-07-2007 02:01:34] Error: Could not re-connect to database server on host '' for status data. I'll keep trying every 60 seconds...

Last edited by hondo; 04-06-2007 at 08:54 PM.
 
Old 04-07-2007, 02:22 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,143

Rep: Reputation: 322Reputation: 322Reputation: 322Reputation: 322
Are you trying to use MySQL with nagios? if som it doesn't look like you gave it proper database login credentials. I think the latest versions don't even support database back ends (but use flat-files instead). If you don't have a database set up you might just try with flat files.
 
Old 04-07-2007, 03:24 PM   #3
hondo
Member
 
Registered: Jul 2005
Location: norway
Posts: 198

Original Poster
Rep: Reputation: 33
Thanks for answering.

I never sat up any mysql server for use with nagios nor have i provided any username or password anywhere in the configuration files. I have no idea where nagios gets this information about any database being used, i have searched for something that would say anything about using a mysql database in the config files, but i didnt find anything.

I do think its a little strange that the log says that there is something wrong with connecting and using a mysqlserver and/or database, because i havent set any directives that should indicate the use of a mysql database server.

I got these packages from the apt-get utility in debian, so it kinda installed itself automatically like all programs when using the apt-get utility.

I have thought about uninstalling this software and install it from source code, but its just that it doesnt seem to be anything wrong with the config files, so i dont really know if it would be any different.

Last edited by hondo; 04-07-2007 at 03:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X not starting up properly after upgrade, need help... Dizaplyn Slackware 1 11-14-2006 07:08 PM
LXer: Nagios 2.5 and Oreon 1.3 (Nagios web front end) installation with screenshots LXer Syndicated Linux News 0 08-11-2006 06:33 PM
LXer: Nagios and Oreon (Nagios web front end) installation and Configuration LXer Syndicated Linux News 0 07-18-2006 09:33 PM
starting nagios problem dwarf007 Linux - Networking 1 11-29-2004 08:36 AM
my mozzila is not starting properly bajaj Linux - Software 0 08-09-2003 05:11 PM


All times are GMT -5. The time now is 07:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration