LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 09-16-2009, 12:45 PM   #1
hoshie66
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Rep: Reputation: 0
Nagios mail Alerts


i have installed the opsview virtual apliance. it is converted to a virtual machine.

i am not getting alerts. I have checked the logs and they are being sent, our company server is rejecting them.

the emails are from nagios@localdomain.l1id.local

how do i remove the localdomain portion of the address.

the /etc/postfix/main.cf file is below:

# WARNING: File managed by puppet
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = yes

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = opsview
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname

mydomain = l1id.local
mydestination =
relayhost = server94.appriver.com
fallback_relay =

mynetworks = 10.165.165.0/24
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = loopback-only

thanks
 
Old 09-16-2009, 04:29 PM   #2
hasienda
Member
 
Registered: May 2009
Location: Saxony, Germany
Distribution: Debian/GNU Linux
Posts: 37

Rep: Reputation: 18
Post

Quote:
Originally Posted by hoshie66 View Post
i have installed the opsview virtual apliance. it is converted to a virtual machine.

i am not getting alerts. I have checked the logs and they are being sent, our company server is rejecting them.

the emails are from nagios@localdomain.l1id.local

how do i remove the localdomain portion of the address.
[...]
I searched with "nagios email alert config" at forestle.org for you. You may want to go i.e. for hit #5

http://www.tuxradar.com/content/nagios-made-easy

Quote:
The default From: line in the email alerts is the Nagios user - this may not be good if you have a mail server that wants a registered address before it will send. If you're using Exim 4, you need to set the 'untrusted user' option, and then add
Code:
-f address@example.com
to the end of the host-notify-by-email and notify-by-email commands in the commands.cfg file.
Good luck.
 
Old 09-17-2009, 09:25 AM   #3
hoshie66
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Original Poster
Rep: Reputation: 0
thank you this worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nagios Server Alerts deibertine Linux - Newbie 2 04-03-2009 08:00 PM
Nagios plugin wont send email alerts investmentbnker75 Programming 0 11-18-2008 09:49 AM
Nagios Alerts on Linux sachinh Linux - Newbie 1 11-05-2008 04:32 PM
Nagios not sending alerts through email lemay_jeff Linux - Networking 2 04-11-2005 11:28 AM
Why is my email (Smailer-Daemon) failing to be delivered (specifically Nagios Alerts) mdwillia Linux - Software 1 11-17-2003 09:16 AM


All times are GMT -5. The time now is 02:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration