LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-18-2006, 02:08 PM   #1
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 733

Rep: Reputation: 37
Question mysqlshow: unknown variable 'loose-local-infile=1'


Hello!
I am running Slackware Linux 11.0 with kernel 2.6.18 and mysql-5.0.24a-i486-1. The client group of my.cnf is:

[client]
password = *******
port = 3306
socket = /var/run/mysql/mysql.sock
loose-local-infile=1

Here I added the last line to enable loading local files into tables. Now everything seems to work fine. Still, I get a strange announcement when I run mysqladmin or mysqlshow:

unknown variable 'loose-local-infile=1'

If I remove the "loose-local-infile=1" line from the [client] group of my.cnf, this message does not appear, but I cannot load files into the database. Now I have that line there and everything works fine. The only issue is that annoying message:
unknown variable 'loose-local-infile=1'
that appears whenever I run mysqladmin or mysqlshow.
Do you have any idea how I could get rid of this and whether it is harmful?
Any suggestions will be appreciated.

Regards,
Martin
 
Old 11-19-2006, 07:55 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
According to MySQL, this is compiled to be enabled by default. Have you tried to just enable it in the /etc/rc.d/rc.mysqld file by passing this option there?

--local-infile=1

Code:
/usr/bin/mysqld_safe --datadir=/var/lib/mysql --pid-file=/var/run/mysql/mysql.pid --local-infile=1
 
Old 11-19-2006, 10:43 AM   #3
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 733

Original Poster
Rep: Reputation: 37
Unhappy

The mysql package that comes by default with Slackware 11.0 obviously does not contain that option compiled. I tried what you suggested, hashed the "loose-local-infile" in my.cnf and added "--local-infile=1" as you suggested as a parameter to mysqld_safe. There was no more "unknown variable: loose-local-infile" message, but I was unable to load text files into the database either. I then unhashed the line in my.cnf, and restarted mysql. This time I could load text files, but the message again appeared.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL Error [mysqld: unknown variable 'old_passwords=1'] after 'apt-get upgrade' jme Debian 10 10-05-2005 07:55 AM
Unknown Local Host MizEllyRolls Linux - Security 3 09-14-2005 08:32 PM
can thread return a local variable? iclinux Programming 1 01-13-2005 11:37 PM
ping: unknown host in local intranet linuxjustin Linux - Networking 3 04-04-2004 02:03 PM
LOAD DATA INFILE error verokard Linux - Newbie 0 07-13-2003 11:02 PM


All times are GMT -5. The time now is 02:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration