LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   mysqld node of mysql cluster system not connecting to management node (http://www.linuxquestions.org/questions/linux-server-73/mysqld-node-of-mysql-cluster-system-not-connecting-to-management-node-640569/)

coal-fire-ice 05-07-2008 11:39 AM

mysqld node of mysql cluster system not connecting to management node
 
i have set up a mysql cluster as described in the documentation for mysql-server-5.0

i have the management node on 1 machine, and then 2 more machines which both have mysqld and ndbd set up on them

as far as i can tell, the management server is working fine, and the ndbd portion of the cluster is also working fine, output from:
Quote:

ndb_mgm>show
Cluster Configuration
---------------------
[ndbd(NDB)] 2 node(s)
id=2 @*.*.*.230 (Version: 5.0.51, starting, Nodegroup: 0)
id=3 @*.*.*.231 (Version: 5.0.51, starting, Nodegroup: 0)

[ndb_mgmd(MGM)] 1 node(s)
id=1 (Version: 5.0.32)

[mysqld(API)] 2 node(s)
id=4 (not connected, accepting connect from any host)
id=5 (not connected, accepting connect from any host)
my problem is whatever i seem to do, the mysqld nodes will not connect to the management node

i have been careful to start the system in the order described in the manual,
both the ndbd/mysqld machines were set up at the same time and are identical.
both the ndbd/mysqld machines run ubuntu server 8.04 and mysql 5.0.51
both the ndbd/mysqld machines are 64 bit xeon machines with the amd64 version of ubuntu
the management server is debian 4.1, and running mysql 5.0.32 it is a celeron with the x86 version of debian
the config file on both the ndbd/mysqld machines is /etc/mysql/my.cnf and it reads:

Quote:

[mysqld]
ndbcluster
ndb-connectstring=management.domain.tld
[mysql_cluster]
ndb-connectstring=management.domain.tld

the config file on the management server is /etc/mysql/ndb_mgmd.cnf and it reads:

Quote:

[ndbd default]
NoOfReplicas=2
DataMemory=80M
IndexMemory=18M

[tcp default]

[ndb_mgmd]
hostname=management.domain.tld
datadir=/var/lib/mysql-cluster

[ndbd]
hostname=db1.domain.tld
datadir=/usr/local/mysql/data

[ndbd]
hostname=db2.domain.tld
datadir=/usr/local/mysql/data

[mysqld]
[mysqld]
to check if i could see the management server from the connecting hosts i did a telnet to port 1186, and then get version command, which returned the correct info

so if anyone has any ideas why the mysqld nodes don't connect i would much appreciate some pointers.
Thanks


All times are GMT -5. The time now is 03:04 PM.