LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 09-03-2006, 08:03 AM   #1
lostnhell
Member
 
Registered: Sep 2005
Location: Virginia Beach, VA
Distribution: Slackware-current
Posts: 50

Rep: Reputation: 17
Question MySQL Setup


I am trying to setup MySQL but it doesn't want to stay an active service. When I attempt to login as root it fails, when I start the service from rc.d it halts, and when I run 'mysql' from bash the output is:
root@ghost:/# mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)


Can someone help me get this running so I can place the schema and tables?

Last edited by lostnhell; 09-03-2006 at 09:23 AM.
 
Old 09-03-2006, 11:48 AM   #2
mindsport
Member
 
Registered: Apr 2005
Location: Florida
Distribution: Slackware 13.1-64bit / 2.6.33.4
Posts: 45

Rep: Reputation: 17
can you post your /etc/my.cnf?
 
Old 09-03-2006, 06:56 PM   #3
lostnhell
Member
 
Registered: Sep 2005
Location: Virginia Beach, VA
Distribution: Slackware-current
Posts: 50

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by mindsport
can you post your /etc/my.cnf?
Attached is myhuge.conf
None of the other resources I was attempting to use referred to this file, it seems to be the right place, but rather than screwing around in the file myself I will await your response.

Code:
# Example MySQL config file for very large systems.
#
# This is for a large system with memory of 1G-2G where the system runs mainly
# MySQL.
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /var/lib/mysql) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password	= your_password
port		= 3306
socket		= /var/run/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port		= 3306
socket		= /var/run/mysql/mysql.sock
skip-locking
key_buffer = 384M
max_allowed_packet = 1M
table_cache = 512
sort_buffer_size = 2M
read_buffer_size = 2M
read_rnd_buffer_size = 8M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size = 32M
# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 8

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
# 
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id	= 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin

# Point the following paths to different dedicated disks
#tmpdir		= /tmp/		
#log-update 	= /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 384M
#bdb_max_lock = 100000

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /var/lib/mysql/
#innodb_data_file_path = ibdata1:2000M;ibdata2:10M:autoextend
#innodb_log_group_home_dir = /var/lib/mysql/
#innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 384M
#innodb_additional_mem_pool_size = 20M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 100M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout
 
Old 09-04-2006, 02:40 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Moved: This thread is more suitable in Linux Server and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 09-04-2006, 04:05 AM   #5
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
firstly you would need to start the service properly, then comes the question of connecting to it. what error do you get when starting sql, paste the command you input to start it and the error.
 
Old 09-04-2006, 07:21 AM   #6
mindsport
Member
 
Registered: Apr 2005
Location: Florida
Distribution: Slackware 13.1-64bit / 2.6.33.4
Posts: 45

Rep: Reputation: 17
your config file looks to be right; did you read the INSTALL file in the source directory and issue all the commands it told you to? there is a few commands to add a mysql user and group and some commands that need to be run as root to get the server started. From INSTALL-SOURCE-5.1.9-BETA
Code:
groupadd mysql
useradd -g mysql mysql
gunzip < mysql-VERSION.tar.gz | tar -xvf -
cd mysql-VERSION
./configure --prefix=/usr/local/mysql
make
make install
cp support-files/my-medium.cnf /etc/my.cnf
cd /usr/local/mysql
bin/mysql_install_db --user=mysql
chown -R root  .
chown -R mysql var
chgrp -R mysql .
bin/mysqld_safe --user=mysql &

Last edited by mindsport; 09-04-2006 at 07:23 AM.
 
Old 09-04-2006, 12:05 PM   #7
lostnhell
Member
 
Registered: Sep 2005
Location: Virginia Beach, VA
Distribution: Slackware-current
Posts: 50

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by mindsport
your config file looks to be right; did you read the INSTALL file in the source directory and issue all the commands it told you to? there is a few commands to add a mysql user and group and some commands that need to be run as root to get the server started. From INSTALL-SOURCE-5.1.9-BETA
Code:
groupadd mysql
useradd -g mysql mysql
gunzip < mysql-VERSION.tar.gz | tar -xvf -
cd mysql-VERSION
./configure --prefix=/usr/local/mysql
make
make install
cp support-files/my-medium.cnf /etc/my.cnf
cd /usr/local/mysql
bin/mysql_install_db --user=mysql
chown -R root  .
chown -R mysql var
chgrp -R mysql .
bin/mysqld_safe --user=mysql &

Actually I just installed the preconpiled TGZ from a slackwae.com mirror. But in light of this I will install the binaries now.
 
Old 09-03-2007, 07:05 PM   #8
redtape
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
IIRC there are two things you have to do in order for mysqld to be started via /etc/rc.d/rc.mysqld.

You must first:
# su - mysql
and then issue the command:
mysql$ mysql_install_db

this should set mysql up for you.
 
Old 09-03-2007, 07:28 PM   #9
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
Quote:
Originally Posted by lostnhell View Post
Attached is myhuge.conf
Did you copy /etc/myhuge.cnf to /etc/my.cnf prior to trying to start mysql?
 
Old 09-03-2007, 07:47 PM   #10
lostnhell
Member
 
Registered: Sep 2005
Location: Virginia Beach, VA
Distribution: Slackware-current
Posts: 50

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by gilead View Post
Did you copy /etc/myhuge.cnf to /etc/my.cnf prior to trying to start mysql?
I just got it running again, the initial problem was that I had attempted to boot the service without the cnf file, to do it properly for a home SQL server I copied my-small.cnf to my.cnf.

The instructions from mindsport do resolve issues with the initial configuration.
 
Old 07-17-2009, 12:55 PM   #11
BrajZore
Member
 
Registered: Sep 2007
Location: Vxj
Distribution: Slackware
Posts: 42

Rep: Reputation: 15
Hi!

I have the same problem..

If I understood all of u correct, should I make a file called my.cnf and copy the content in my-small.cnf into my.cnf?
 
Old 07-20-2009, 04:39 AM   #12
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 748
Blog Entries: 6

Rep: Reputation: 74
BrajZore

any way also work

you can copy my-small.cnf put in /etc/ and named as my.cnf
or
you make symlink /etc/my.cnf point to /path/mysql/support-files/my-small.cnf

as long as my.cnf inside /etc/ or inside ~/ mysql user
 
Old 07-20-2009, 05:56 AM   #13
whho
Member
 
Registered: Feb 2009
Posts: 38

Rep: Reputation: 16
Quote:
Originally Posted by lostnhell View Post
I am trying to setup MySQL but it doesn't want to stay an active service. When I attempt to login as root it fails, when I start the service from rc.d it halts, and when I run 'mysql' from bash the output is:
root@ghost:/# mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)


Can someone help me get this running so I can place the schema and tables?
Have you tried:

mysql -h 127.0.0.1
 
Old 07-26-2009, 03:32 PM   #14
BrajZore
Member
 
Registered: Sep 2007
Location: Vxj
Distribution: Slackware
Posts: 42

Rep: Reputation: 15
Hi everyone!

It want work.
When i'm trying to connect to MySQL, this message appears:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)


When i'm typing in mysql -h 127.0.0.1, this message appears:
ERROR 2003 (HY000): Can't connect to MySQL server on '127.0.0.1' (111)

I have a file called my.cnf in /etc/, but the MySQL want work.

Can somebody help me?
 
Old 07-26-2009, 11:44 PM   #15
whho
Member
 
Registered: Feb 2009
Posts: 38

Rep: Reputation: 16
Quote:
Originally Posted by BrajZore View Post
Hi everyone!

It want work.
When i'm trying to connect to MySQL, this message appears:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)


When i'm typing in mysql -h 127.0.0.1, this message appears:
ERROR 2003 (HY000): Can't connect to MySQL server on '127.0.0.1' (111)

I have a file called my.cnf in /etc/, but the MySQL want work.

Can somebody help me?
I think it would be helpful if you post the output of:

ps -elf | grep mysql

netstat -anpt | grep -E "3306|mysql"

Thanks!

whho
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to setup mysql for mythtv?? jadukor Slackware 9 04-13-2006 01:01 AM
MySQL setup. sikofitt Programming 1 09-29-2005 04:43 AM
How to setup MySQL in mandrake? sebasjuh Mandriva 1 09-10-2004 07:03 AM
MySQL setup stops at command "./configure --prefix=/usr/local/mysql" k41184 Linux - Software 1 05-20-2004 02:44 PM
How do you setup a mysql database brandog Linux - Newbie 15 03-24-2003 06:13 PM


All times are GMT -5. The time now is 11:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration