LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-07-2010, 02:57 PM   #1
dreamer.redeemer
LQ Newbie
 
Registered: Jan 2008
Distribution: Ubuntu, Suse 11, etc...
Posts: 20

Rep: Reputation: 0
mysql plugin directory vanished?


This server (running suse 11.1) was approaching a year of uptime when last night it became unresponsive @ max cpu and was given a hard reset. Suddenly mysql no longer works, it fails to secure a socket and shuts down. The error log says it can't load a bunch of stuff in /usr/lib/mysql/plugin/ because there's no such directory, then aborts after the unknown option --skip-federated. If I comment out skip-federated in /etc/my.cnf mysql will start, but users get access denied--I can't say if the same is true for root, I don't have root credentials for mysql.

This is all very funny because I need to finish/present my final project in a few hours and also happen to be the server admin, yet haven't been able to dig myself out of this hole, 5 hours has produced virtually no progress. Any help would be profoundly appreciated.
 
Old 12-07-2010, 10:27 PM   #2
dreamer.redeemer
LQ Newbie
 
Registered: Jan 2008
Distribution: Ubuntu, Suse 11, etc...
Posts: 20

Original Poster
Rep: Reputation: 0
As I suspected, I was just approaching it wrong. The solution was to start the mysql daemon with the very specific command
Code:
/usr/local/mysql/bin/mysqld_safe  --innodb --user=mysql &
though it took a bit more to get all the tables up. I had tried various other ways of starting, and though they provoked some sign of life, clearly they weren't correct.
 
  


Reply

Tags
mysql


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] firefox plugin directory kaz2100 Linux - Software 11 05-06-2014 09:31 PM
Cannot uninstall flash-plugin from Yast (I've deleted "Flash-Plugin" directory" ibovey Linux - Software 1 08-16-2010 08:45 AM
My /etc/X11 directory vanished dickgregory Linux - General 4 07-27-2007 10:14 AM
MySQL + plugin help!! Alexander.s Programming 1 02-14-2005 04:14 PM
Openwebmail Mail Directory dropdown numbers vanished Apollo77 Linux - Software 1 08-20-2004 09:00 PM


All times are GMT -5. The time now is 11:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration