LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 01-28-2010, 07:56 PM   #1
ericyao
LQ Newbie
 
Registered: Jan 2010
Posts: 18

Rep: Reputation: 0
mount -t cifs without password


Hi All

I have one NAS device and using samba share one folder without password, how can I use command mount -t cifs to mount this share folder? I tried the below command, but always popup password checking?
How should I do mount this folder without password checking?


#mount -t cifs -o user=nobody.password=nobody //192.168.0.253MailBackup /MailBackup
Password:
 
Old 01-29-2010, 12:53 PM   #2
kforbus
Member
 
Registered: Sep 2009
Location: Maryland
Distribution: Slackware
Posts: 68

Rep: Reputation: 28
Quote:
Originally Posted by ericyao View Post
Hi All

I have one NAS device and using samba share one folder without password, how can I use command mount -t cifs to mount this share folder? I tried the below command, but always popup password checking?
How should I do mount this folder without password checking?


#mount -t cifs -o user=nobody.password=nobody //192.168.0.253MailBackup /MailBackup
Password:
Since you are specifying a password in the command: Try replacing the "." between the samba user and password with a comma ",".

Another way to do this password-less would be to add the line "guest account = nobody" to your smb.conf and the line "guest ok = yes" to your share definition in smb.conf. Then you can change your mount command to:

#mount -t cifs -o guest //192.168.0.253/MailBackup /MailBackup

Last edited by kforbus; 01-29-2010 at 01:03 PM.
 
Old 01-29-2010, 01:01 PM   #3
slacker_et
Member
 
Registered: Dec 2009
Distribution: Slackware
Posts: 113

Rep: Reputation: 23
Either mount it using the "guest" option, or use a "credentials" file to supply the domain, username, and password.

Personally I've never used the "guest" option. And I routinely use a credentials file.

Example of specifying a credentials file:
Code:
mount -t cifs //servername/mylogin /home/mylogin/windows -o uid=mylogin -o gid=groupname -o credentials=/home/mylogin/winpasswd
Example of a credentials file:
Code:
username=mylogin
domain=domainname
password=password_in_plain_text
And permissions on the credentials file are so that only the owner can read it.

--ET

Last edited by slacker_et; 01-29-2010 at 01:05 PM.
 
Old 01-30-2010, 07:50 AM   #4
ericyao
LQ Newbie
 
Registered: Jan 2010
Posts: 18

Original Poster
Rep: Reputation: 0
Hi

Thanks, my question has been fixed, thanks all who replied this thread, this web-site is very useful ^^
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
manual mount cifs works but srcipt mount cifs has mount error (13): Permission denied CADIT Linux - Newbie 6 11-20-2009 03:48 PM
cifs mount "password too long" abylin1 Linux - Newbie 1 12-24-2008 06:44 PM
FC9 Upgrade Woes: mount.cifs hangs after password prompt livnah Linux - Networking 0 06-13-2008 04:24 AM


All times are GMT -5. The time now is 12:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration