LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Missing Dependency: php-common = 5.1.6-27.el5_7.4 is needed by package php-gd-5.1.6-2 (http://www.linuxquestions.org/questions/linux-server-73/missing-dependency-php-common-%3D-5-1-6-27-el5_7-4-is-needed-by-package-php-gd-5-1-6-2-a-925479/)

paul1107 01-24-2012 12:38 PM

Missing Dependency: php-common = 5.1.6-27.el5_7.4 is needed by package php-gd-5.1.6-2
 
I run a linux server with centos

I run some wordpress sites and for a contact form I need to add GD and Free Type libraries for the captcha services.

I ran

# yum install gd gd-devel php-gd

then

# /etc/init.d/httpd restart

It seemed to load OK, however over at wordpress I was still getting the error message to say GD and Free Type need to be installed.

I contacted my support and the replied with following:

Quote:

I notice when trying to install GD it looks like there are some dependencies missing:

Resolving Dependencies
--> Running transaction check
---> Package php-gd.i386 0:5.1.6-27.el5_7.4 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_7.4 for package: php-gd
--> Finished Dependency Resolution
php-gd-5.1.6-27.el5_7.4.i386 from updates has depsolving problems
--> Missing Dependency: php-common = 5.1.6-27.el5_7.4 is needed by package php-gd-5.1.6-27.el5_7.4.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-27.el5_7.4 is needed by package php-gd-5.1.6-27.el5_7.4.i386 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

You may need to install any of these before getting GD to install. Once those are installed give it another try and see if it will complete.
I've tried doing a search, but there nothing that gives me any clues as to how resolve this.

I was hoping you guys may be able to point me in the right direction?

cheers!

Satyaveer Arya 01-25-2012 01:47 AM

Have you tried installing package with these options as shown above when you get the error message :

Quote:

You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

deep27ak 01-25-2012 04:29 AM

manually download the missing dependency and try re installing the package

here have a link or you can hit a search on google for other links

http://rpm.pbone.net/index.php3/stat....i386.rpm.html


All times are GMT -5. The time now is 11:07 PM.