LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   mdadm - invalid raid superblock magic (http://www.linuxquestions.org/questions/linux-server-73/mdadm-invalid-raid-superblock-magic-4175437850/)

czezz 11-19-2012 05:06 PM

mdadm - invalid raid superblock magic
 
I have created a simple RAID-1 with mdadm (2 disks with 1 fs to keep samba shares ).
After system reboot I can see in syslog this error:

Code:

Nov 19 22:38:19 general kernel: [    2.260956] md: invalid raid superblock magic on sdc1
Nov 19 22:38:19 general kernel: [    2.261071] md: sdc1 does not have a valid v0.90 superblock, not importing!
Nov 19 22:38:19 general kernel: [    2.284211] md: invalid raid superblock magic on sdb1
Nov 19 22:38:19 general kernel: [    2.284316] md: sdb1 does not have a valid v0.90 superblock, not importing!

What I have googled is that:
Quote:

This is because mdadm version 2.5 uses a version 1.0 superblock which does not support in-kernel auto-detection. To verify this, just cat /proc/mdstat | grep super, and you will see 'super 1.0'
Well, my mdadm is: mdadm - v3.2.5 - 18th May 2012
and superbock seems to be 1.2.

Anyway, RAID-1 seems to be working correctly but I am worried about this errors in syslog.
Is there anyway to correct it/how to correct it ?

tristezo2k 11-19-2012 06:09 PM

Yes, it seems to be related to the kernel MD autodetection scheme.
what is the output of mdadm -D /dev/md*
Have you put the md device on /etc/mdadm/mdadm.conf ?
You can do so using
mdadm -Es >> /etc/mdadm/mdadm.conf

There is some information here: http://forums.gentoo.org/viewtopic-t...4-start-0.html

Regards,
Sebastian

czezz 11-19-2012 06:29 PM

Hello Sebastian and thank you for your reply.
Here is an output of mdadm -D

Code:

# mdadm -D /dev/md*
/dev/md0:
        Version : 1.2
  Creation Time : Sun Nov 18 19:31:38 2012
    Raid Level : raid1
    Array Size : 976631296 (931.39 GiB 1000.07 GB)
  Used Dev Size : 976631296 (931.39 GiB 1000.07 GB)
  Raid Devices : 2
  Total Devices : 2
    Persistence : Superblock is persistent

    Update Time : Mon Nov 19 22:38:19 2012
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

          Name : general:0  (local to host general)
          UUID : 11a52b80:c11bada1:37c614d5:d6417ebc
        Events : 19

    Number  Major  Minor  RaidDevice State
      0      8      17        0      active sync  /dev/sdb1
      1      8      33        1      active sync  /dev/sdc1

My config file is in this location: /etc/mdadm.conf and I have added following line manually
Code:

ARRAY /dev/md0 devices=/dev/sdb1,/dev/sdc1 level=1 num-devices=2 auto=yes
If that matters, this is Slackware 14
Code:

# uname -a
Linux general 3.2.29 #2 SMP Mon Sep 17 14:19:22 CDT 2012 x86_64 Intel(R) Xeon(R) CPU          X3220  @ 2.40GHz GenuineIntel GNU/Linux


czezz 11-25-2012 07:36 AM

There is a workaround how to change superblock at this link:
http://marc.info/?l=linux-raid&m=130895284716309&w=2
However, I must warn you all. I tried to do that with RAID1 and when I tried to mount file system again I faced this error:
Code:

# mount /opt
mount: wrong fs type, bad option, bad superblock on /dev/md0,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so



All times are GMT -5. The time now is 03:14 AM.