LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-16-2010, 11:22 PM   #1
DavidDiggs
LQ Newbie
 
Registered: May 2007
Posts: 12

Rep: Reputation: 0
Exclamation MDADM Help - "not enough to start the array while not clean - consider --force."


I powered down my file server this morning and started it back up a little while ago. One of the drive in a raid 6 array hung the system if it's inserted so after a little tomfoolery to identify the trouble drive. After removing it I finally have it booting but the raid array come up as inactive and all spares.

I've "mdadm --examined" all the remaining drive in the drive in the raid6 array and the "events" are all the same, "2085124".

When I assemble the array I get

Code:
mdadm --assemble /dev/md1 /dev/sdd1 /dev/sde1 /dev/sdf1 /dev/sdh1 /dev/sdi1 /dev/sdj1 /dev/sdg1
mdadm: /dev/md1 assembled from 6 drives and 1 spare - not enough to start the array while not clean - consider --force.
Can the array be safely started using the --force option?

Any assitance would be greatly appreciated.

Below is the details of one of the drives.

Code:
/dev/sdd1:
          Magic : a92b4efc
        Version : 00.90.00
           UUID : 08ad285e:ba1e0d5a:38cad0b1:c61c5ee7
  Creation Time : Wed May 20 14:29:17 2009
     Raid Level : raid6
  Used Dev Size : 976759936 (931.51 GiB 1000.20 GB)
     Array Size : 4883799680 (4657.55 GiB 5001.01 GB)
   Raid Devices : 7
  Total Devices : 8
Preferred Minor : 1

    Update Time : Tue Feb 16 15:14:50 2010
          State : active
 Active Devices : 7
Working Devices : 8
 Failed Devices : 0
  Spare Devices : 1
       Checksum : 3ae60447 - correct
         Events : 2085124

     Chunk Size : 64K

      Number   Major   Minor   RaidDevice State
this     3       8       49        3      active sync   /dev/sdd1

   0     0       8      145        0      active sync   /dev/sdj1
   1     1       8      129        1      active sync   /dev/sdi1
   2     2       8       65        2      active sync   /dev/sde1
   3     3       8       49        3      active sync   /dev/sdd1
   4     4       8      113        4      active sync   /dev/sdh1
   5     5       8      161        5      active sync
   6     6       8       97        6      active sync   /dev/sdg1
   7     7       8       81        7      spare   /dev/sdf1
 
Old 02-17-2010, 01:26 AM   #2
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,311

Rep: Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040
Did you only physically remove the disk, or did you also tell the array it was dead & gone?

eg

mdadm --fail /dev/md1 /dev/sdx1
mdadm --remove /dev/md1 /dev/sdx1


replace sdx1 with correct value.
 
Old 03-27-2010, 09:55 PM   #3
DavidDiggs
LQ Newbie
 
Registered: May 2007
Posts: 12

Original Poster
Rep: Reputation: 0
Sorry to bring this up. Just figured I'd post my findings.

The drive had to be physically remove. The system would not boot with the drive in.

Being a raid 6 array with one drive out I did as the message said and used the --force option.

I replaced the drive and everything rebuilt correctly and is running smoothly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mdadm create,, raid array is not clean dbj Linux - Server 2 11-16-2009 06:36 PM
mdadm says "mdadm: /dev/md1 not identified in config file" when booting FC7 raffeD Linux - Server 1 08-11-2008 12:47 PM
mdadm: fails to assemble array. All 8 devices report being "slot 0" mesosphere Linux - General 1 06-11-2008 11:42 AM
Microsoft "new" patent could "force" downloaders to view commercials!! Hitboxx General 12 12-27-2007 10:05 AM
RAID 5 with mdadm "spare" and "active sync" confusion ufmale Linux - Server 1 12-08-2007 11:31 AM


All times are GMT -5. The time now is 04:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration