LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   login problem (http://www.linuxquestions.org/questions/linux-server-73/login-problem-4175440437/)

vidyasagar6 12-07-2012 08:27 AM

login problem
 
when i am going to login in quotauser(user name) i m geting a message called

your session only lasted less than 10 seconds.If you Have not logged out yourself this could mean that there is some installation problem or that you may be out of diskspace.try logging in with one of the failsafe sessions to see if you can fix this problem.

view details ( /.xsession.errors.file ).

note :i configured quota to this user

tallship 12-08-2012 05:40 AM

So show us the configs, and pls provide us with the other information too that we'll need to help troubleshoot your problem - i.e., are you really telling us that you're trying to login to a Windows XP machine where you've configured quotas for a user called *quotauser*????

Because that's what your browsers user agent says your running when you ask these questions. If so, you should ask those questions in a windows forum or rummage through technet.

If not, we're going to need a bit more than just your word that you configured something, leaving us to guess what you're running and what went wrong.

vidyasagar6 12-08-2012 11:11 AM

I am going to login in linux machine only and quotauser is a user in linux pc when he is going to login it showing message

your session only lasted less than 10 seconds.If you Have not logged out yourself this could mean that there is some installation problem or that you may be out of diskspace.try logging in with one of the failsafe sessions to see if you can fix this problem.

view details ( /.xsession.errors.file ).

and before configuring quota feature it is working fine.after setting quota to quotauser m not able to login.below i m giving /etc/fstab file
LABEL=/ / ext3 defaults 1 1
LABEL=/home /home ext3 defaults,usrquota,grpquota 1 2
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
LABEL=SWAP-sda3 swap swap defaults 0 0

and /etc/passwd file:

root:x:0:0:redhat:/root:/bin/bash
bin:x:1:1:bin:/bin:/sbin/nologin
daemon:x:2:2:daemon:/sbin:/sbin/nologin
adm:x:3:4:adm:/var/adm:/sbin/nologin
lp:x:4:7:lp:/var/spool/lpd:/sbin/nologin
sync:x:5:0:sync:/sbin:/bin/sync
shutdown:x:6:0:shutdown:/sbin:/sbin/shutdown
halt:x:7:0:halt:/sbin:/sbin/halt
mail:x:8:12:mail:/var/spool/mail:/sbin/nologin
news:x:9:13:news:/etc/news:
uucp:x:10:14:uucp:/var/spool/uucp:/sbin/nologin
operator:x:11:0:operator:/root:/sbin/nologin
games:x:12:100:games:/usr/games:/sbin/nologin
gopher:x:13:30:gopher:/var/gopher:/sbin/nologin
ftp:x:14:50:FTP User:/home/sharedfiles:/sbin/nologin
nobody:x:99:99:Nobody:/:/sbin/nologin
nscd:x:28:28:NSCD Daemon:/:/sbin/nologin
vcsa:x:69:69:virtual console memory owner:/dev:/sbin/nologin
pcap:x:77:77::/var/arpwatch:/sbin/nologin
ntp:x:38:38::/etc/ntp:/sbin/nologin
dbus:x:81:81:System message bus:/:/sbin/nologin
rpc:x:32:32:Portmapper RPC user:/:/sbin/nologin
avahi:x:70:70:Avahi daemon:/:/sbin/nologin
mailnull:x:47:47::/var/spool/mqueue:/sbin/nologin
smmsp:x:51:51::/var/spool/mqueue:/sbin/nologin
sshd:x:74:74:Privilege-separated SSH:/var/empty/sshd:/sbin/nologin
rpcuser:x:29:29:RPC Service User:/var/lib/nfs:/sbin/nologin
nfsnobody:x:65534:65534:Anonymous NFS User:/var/lib/nfs:/sbin/nologin
haldaemon:x:68:68:HAL daemon:/:/sbin/nologin
avahi-autoipd:x:100:101:avahi-autoipd:/var/lib/avahi-autoipd:/sbin/nologin
xfs:x:43:43:X Font Server:/etc/X11/fs:/sbin/nologin
gdm:x:42:42::/var/gdm:/sbin/nologin
redhat:x:500:500::/home/redhat:/bin/bash
shift1:x:501:501::/home/user/:/bin/bash
shift2:x:502:502::/var/ftp:/bin/bash
ftpuser0:x:503:503::/home/sharedfiles:/bin/bash
user0:x:504:504::/home/user0:/bin/bash
user1:x:505:506::/home/user1:/bin/bash
administrator:x:506:507::/home/administrator:/bin/bash
mnguser:x:507:508::/home/sharedfiles:/bin/bash
ftpuser1:x:508:509::/www/ftpuser1_dir:/sbin/nologin
pvuser:x:509:510::/home/pvuser:/bin/bash
blruser:x:510:511::/home/blruser:/bin/bash
mysuser:x:511:512::/home/mysuser:/bin/bash
samba:x:511:513::/home/samba:/bin/bash
satish:x:512:514::/home/satish:/bin/bash
bhai0:x:513:515::/home/bhai0:/bin/bash
quotauser:x:514:516::/home/quotauser:/bin/bash
test:x:515:517::/home/test:/bin/bash

and

i set quota to qutauser
and file is below

Disk quotas for user quotauser (uid 514):
Filesystem blocks soft hard inodes soft hard
/dev/sda5 112 600000000 600000000 14 0 0

vidyasagar6 12-10-2012 03:45 AM

Any Update???

tallship 12-10-2012 06:20 AM

Quote:

Originally Posted by vidyasagar6 (Post 4845239)
Code:

your session only lasted less than 10 seconds.

Let's not login via X. login via console, switch to runlevel 3 (If this is a redhat box) or ssh like so:

Code:

$ ssh quotauser@yourbox.sld.tld
Does this work for you? And if not, make sure that another non-priviliged user can login. Check and see by trying to login as one of the users in your /etc/passwd below, i.e., user0 or user1...

Code:

$ ssh user0@yourbox.sld.tld
And what happens when you login as root, open a terminal, and then:

Code:

# su quotauser
$ quota


Paste any errors you receive and from your logfiles in /var/log... at your favorite pastebin or here if you like:

http://codepad.org/

Quote:

Originally Posted by vidyasagar6 (Post 4845239)
and before configuring quota feature it is working fine.after setting quota to quotauser m not able to login.

Understood.

Quote:

Originally Posted by vidyasagar6 (Post 4845239)
Code:

LABEL=/home            /home                  ext3 defaults,usrquota,grpquota        1 2

So... /home is mounted on the /dev/sda5 partition? Are you sure?

And do you need group quotas too? Because if all you need are user level quotas then you can remove the other.

What does /etc/mtab say? please post it so we can see.

Code:

# cat /etc/mtab
Quote:

Originally Posted by vidyasagar6 (Post 4845239)
Code:

root:x:0:0:redhat:/root:/bin/bash

redhat:x:500:500::/home/redhat:/bin/bash

user0:x:504:504::/home/user0:/bin/bash
user1:x:505:506::/home/user1:/bin/bash

quotauser:x:514:516::/home/quotauser:/bin/bash


This is a redhat box? Yes or no. What version?


Quote:

Originally Posted by vidyasagar6 (Post 4845239)
i set quota to qutauser
and file is below

qutauser? or quoatauser?

And what filename are you talking about above? /home/quota.user or /home/aquota.user ??? This is important because redhat changed the file that is used for this.

Paste the output from the following commands:

Code:

# ls -la /home/aquota.user
# quota -u quotauser
# quotacheck -vmug /home
# repquota -suvg /home

aquota.user should be chmod'd to 600 and owned by root:root

Quote:

Originally Posted by vidyasagar6 (Post 4845239)
Code:

Disk quotas for user quotauser (uid 514):
  Filesystem                  blocks      soft      hard    inodes    soft    hard
  /dev/sda5                      112  600000000  600000000        14        0        0


You're sure about this? What command did you run or file did you cat for this?

What else have you edited?

Can this user logon after running quotaoff? Did you run quotaon?

One thing I want to make sure of is that /dev/sda5 is where /home is mounted and not on some other partition. Output from some of the commands I'm asking you to run and post results from should clarify this.

I hope that helps and it should keep you busy for a while ;)

Kindest regards,

.


All times are GMT -5. The time now is 07:07 AM.