LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-10-2012, 04:06 AM   #1
Reignfire
Member
 
Registered: Jun 2012
Posts: 56

Rep: Reputation: Disabled
libc problem cause of accidental install


Hi,

I accidentally ran the following script on my server and now i keep having an error.

I ran this script on my debian server but it should have been on my ubuntu execution host.
Code:
#!/bin/bash

sudo dpkg -i openssl_1.0.1c-3ubuntu2_amd64.deb
sudo dpkg -i ssl-cert_1.0.32_all.deb
sudo dpkg -i tcsh_6.18.01-2_amd64.deb
sudo dpkg -i postfix_2.9.3-2ubuntu2_amd64.deb
sudo dpkg -i bsd-mailx_8.1.2-0.20111106cvs-1build1_amd64.deb
sudo dpkg -i gridengine-common_6.2u5-7.1ubuntu1_all.deb
sudo dpkg -i gridengine-client_6.2u5-7.1ubuntu1_amd64.deb
sudo dpkg -i gridengine-exec_6.2u5-7.1ubuntu1_amd64.deb
Code:
test@server:/nfs/share/gridengine$ sudo sh script.sh
(Reading database ... 35357 files and directories currently installed.)
Preparing to replace openssl 0.9.8o-4squeeze13 (using openssl_1.0.1c-3ubuntu2_am                               d64.deb) ...
Unpacking replacement openssl ...
dpkg: dependency problems prevent configuration of openssl:
 openssl depends on libc6 (>= 2.15); however:
  Version of libc6 on system is 2.11.3-4.
 openssl depends on libssl1.0.0 (>= 1.0.1); however:
  Package libssl1.0.0 is not installed.
dpkg: error processing openssl (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 openssl
Selecting previously deselected package ssl-cert.
(Reading database ... 35074 files and directories currently installed.)
Unpacking ssl-cert (from ssl-cert_1.0.32_all.deb) ...
dpkg: dependency problems prevent configuration of ssl-cert:
 ssl-cert depends on openssl (>= 0.9.8g-9); however:
  Package openssl is not configured yet.
dpkg: error processing ssl-cert (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 ssl-cert
(Reading database ... 35083 files and directories currently installed.)
Preparing to replace tcsh 6.17.02-4 (using tcsh_6.18.01-2_amd64.deb) ...
Unpacking replacement tcsh ...
dpkg: dependency problems prevent configuration of tcsh:
 tcsh depends on libc6 (>= 2.14); however:
  Version of libc6 on system is 2.11.3-4.
 tcsh depends on libtinfo5; however:
  Package libtinfo5 is not installed.
dpkg: error processing tcsh (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 tcsh
Selecting previously deselected package postfix.
dpkg: regarding postfix_2.9.3-2ubuntu2_amd64.deb containing postfix:
 postfix conflicts with mail-transport-agent
  exim4-daemon-light provides mail-transport-agent and is present and installed.
dpkg: error processing postfix_2.9.3-2ubuntu2_amd64.deb (--install):
 conflicting packages - not installing postfix
Errors were encountered while processing:
 postfix_2.9.3-2ubuntu2_amd64.deb
(Reading database ... 35100 files and directories currently installed.)
Preparing to replace bsd-mailx 8.1.2-0.20100314cvs-1 (using bsd-mailx_8.1.2-0.20                               111106cvs-1build1_amd64.deb) ...
Unpacking replacement bsd-mailx ...
dpkg: dependency problems prevent configuration of bsd-mailx:
 bsd-mailx depends on libc6 (>= 2.14); however:
  Version of libc6 on system is 2.11.3-4.
dpkg: error processing bsd-mailx (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 bsd-mailx
(Reading database ... 35099 files and directories currently installed.)
Preparing to replace gridengine-common 6.2u5-7.1ubuntu1 (using gridengine-common                               _6.2u5-7.1ubuntu1_all.deb) ...
Unpacking replacement gridengine-common ...
dpkg: dependency problems prevent configuration of gridengine-common:
 gridengine-common depends on bsd-mailx | mailx; however:
  Package bsd-mailx is not configured yet.
  Package mailx is not installed.
  Package bsd-mailx which provides mailx is not configured yet.
dpkg: error processing gridengine-common (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 gridengine-common
(Reading database ... 35099 files and directories currently installed.)
Preparing to replace gridengine-client 6.2u5-1squeeze1 (using gridengine-client_                               6.2u5-7.1ubuntu1_amd64.deb) ...
Unpacking replacement gridengine-client ...
dpkg: dependency problems prevent configuration of gridengine-client:
 gridengine-client depends on libc6 (>= 2.15); however:
  Version of libc6 on system is 2.11.3-4.
 gridengine-client depends on gridengine-common; however:
  Package gridengine-common is not configured yet.
dpkg: error processing gridengine-client (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 gridengine-client
(Reading database ... 35100 files and directories currently installed.)
Preparing to replace gridengine-exec 6.2u5-1squeeze1 (using gridengine-exec_6.2u                               5-7.1ubuntu1_amd64.deb) ...
Unpacking replacement gridengine-exec ...
dpkg: dependency problems prevent configuration of gridengine-exec:
 gridengine-exec depends on libc6 (>= 2.15); however:
  Version of libc6 on system is 2.11.3-4.
 gridengine-exec depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0 is not installed.
 gridengine-exec depends on gridengine-common; however:
  Package gridengine-common is not configured yet.
 gridengine-exec depends on tcsh | c-shell; however:
  Package tcsh is not configured yet.
  Package c-shell is not installed.
  Package tcsh which provides c-shell is not configured yet.
dpkg: error processing gridengine-exec (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 gridengine-exec
test@server:/nfs/share/gridengine$ qstat -f
/usr/lib/gridengine/qstat: /lib/libc.so.6: version `GLIBC_2.14' not found (requi                               red by /usr/lib/gridengine/qstat)
Now i always get this error:

/usr/lib/gridengine/qstat: /lib/libc.so.6: version `GLIBC_2.14' not found (requi red by /usr/lib/gridengine/qstat)

Debian uses an early version of glibc_2.14 but cause i installed the ubuntu packages it isn't working anymore. Can i just purge the packages i installed or would that cause even more problems?
 
Old 12-11-2012, 03:14 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,671
Blog Entries: 54

Rep: Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953Reputation: 2953
Quote:
Originally Posted by Reignfire View Post
Can i just purge the packages i installed or would that cause even more problems?
If the kernel is the "heart" of your Linux system then the Glibc package is one of its valves: without it the blood won't be pumped around. Heart surgery for you will involve replacing / forcing / downgrading the package in place. (Or restore from backup but that kinda skews the analogy as you don't backup heart valves.)
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub accidental install onto partitions. Windows no longer booting. Possible restore? alexhtyler Linux - Newbie 5 01-26-2012 01:29 PM
How to install dependencies libc.so.6 without yum JATA01 Linux - Software 1 08-29-2010 02:00 AM
Cannot install cinelerra because it says I don't have libc.so.6 - BUT I DO! ForYouAndI.com Linux - Software 5 11-26-2006 03:34 PM
Serious problem: Accidental chmod -R 777 / neocookie Linux - General 4 05-15-2006 04:41 AM
Accidental Install of Windows Second....Install GRUB? Brnzwngs Linux - Newbie 6 08-12-2005 02:10 PM


All times are GMT -5. The time now is 09:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration