LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 03-20-2013, 08:21 AM   #1
dushyantmdave
LQ Newbie
 
Registered: Aug 2012
Location: India
Posts: 8

Rep: Reputation: Disabled
Angry ldap_bind: Invalid credentials (49)


Hello,

I got error while inserting records in to LDAP
please help me

ldapadd -x -D cn=root,dc=elitecore,dc=in,ou=test -w secret -f user2.ldif
ldap_bind: Invalid credentials (49)


Thanks & Regards
Dushyant Dave
 
Old 03-20-2013, 08:27 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
Exactly as the error says... the password is wrong. Or it's almost certainly wrong, I think this *could* be caused by not having a password field in the record, or an expired password, but it's unlikely to be either of those. Maybe you need to esscape special characters in the password? try putting it in 'single quotes' to be sure.
 
Old 03-20-2013, 08:42 AM   #3
dushyantmdave
LQ Newbie
 
Registered: Aug 2012
Location: India
Posts: 8

Original Poster
Rep: Reputation: Disabled
I Tried all the things crypt ssh md5 but still , the error is same and when I am using from Windows GUI it is working fine.
I don't understand the problem.
I am using RHEL 5.3 32bit
 
Old 03-20-2013, 08:47 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
all the things??? what things?
 
Old 03-20-2013, 10:03 AM   #5
dushyantmdave
LQ Newbie
 
Registered: Aug 2012
Location: India
Posts: 8

Original Poster
Rep: Reputation: Disabled
Angry

I have tried with root password with different methods like ssh/crypt and md5 with slapdpasswd
please find attached slapd.conf
Attached Files
File Type: txt slapd.conf.txt (3.8 KB, 7 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ldap_bind: Invalid credentials (49) pdrobe Linux - General 12 09-13-2012 03:41 AM
ldap_bind: Invalid credentials (49) packets Linux - Software 1 02-19-2012 07:57 AM
ldap_bind: Invalid credentials (49) soni_silver17 Linux - Server 1 01-24-2009 02:47 PM
LDAP_BIND: Invalid Credentials rupesh_pulikool Linux - Software 0 02-01-2005 02:27 PM
ldap_bind:Invalid credentials chintone Linux - General 0 12-06-2002 06:42 AM


All times are GMT -5. The time now is 03:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration