LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 12-17-2008, 03:18 PM   #1
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Rep: Reputation: 25
LAMP with Debian Etch on a Virtual Machine & Leopard as host


Hi Guys

I am trying to install LAMP on Debian Etch VM. I have installed LAMP following the link below but now I am faced with problems

http://linux.justinhartman.com/Setting_up_a_LAMP_Server

when i restart my web server i get this error message

' Forcing reload of web server (apache2)...httpd no pid file not running
(98) address already in use: make_sock: could not bind to address {::}:80
(98) address already in use: make_sock: could not bind to address 0.0.0.0: 80
no listening sockets available, shutting down. Unable to open logs

I would really appreciate your help out there. I am really stuck and don't really know where to look. Is the problem due to the fact that I am running Debian in a VM? I do understand that there is no socket available for the webserver to listen too but do not know how to fix that problem.

Thank You.

Riganta
 
Old 12-17-2008, 03:46 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,107

Rep: Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720
Quote:
Originally Posted by riganta View Post
Hi Guys

I am trying to install LAMP on Debian Etch VM. I have installed LAMP following the link below but now I am faced with problems

http://linux.justinhartman.com/Setting_up_a_LAMP_Server

when i restart my web server i get this error message

' Forcing reload of web server (apache2)...httpd no pid file not running
(98) address already in use: make_sock: could not bind to address {::}:80
(98) address already in use: make_sock: could not bind to address 0.0.0.0: 80
no listening sockets available, shutting down. Unable to open logs

I would really appreciate your help out there. I am really stuck and don't really know where to look. Is the problem due to the fact that I am running Debian in a VM? I do understand that there is no socket available for the webserver to listen too but do not know how to fix that problem.

Thank You.

Riganta
Something else is using port 80. Either your Apache server never really stopped, you're trying to start a second instance on the same port, or some other program grabbed port 80.

Do an apache full-stop, then do a "ps -ef | grep htt", to see if you've still got a thread running. If you see any httpd stuff running, and you're SURE things are ok, kill -9 those PID's. After that, crank Apache back up.

If everything does stop, then you'll have to find out what other services could be running on port 80, and either change them, or change Apache, to use a different port.

Last edited by TB0ne; 12-17-2008 at 03:49 PM.
 
Old 12-18-2008, 03:17 AM   #3
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
how can I simply find out what is taking my port 80 and kill it in my VM ?
I ran a test and configured apache to run on port 443. My Web Server started without any problem. As soon as i put port 80 i get the same error message.
I ran ps -ef | grep htt as advised by TB0ne but i didn't get any result at all. There is nothing that seems to be running at all on port 80.

I thank you all for your help.

Riganta

Quote:
Originally Posted by TB0ne View Post
Something else is using port 80. Either your Apache server never really stopped, you're trying to start a second instance on the same port, or some other program grabbed port 80.

Do an apache full-stop, then do a "ps -ef | grep htt", to see if you've still got a thread running. If you see any httpd stuff running, and you're SURE things are ok, kill -9 those PID's. After that, crank Apache back up.

If everything does stop, then you'll have to find out what other services could be running on port 80, and either change them, or change Apache, to use a different port.
I have done "ps -ef | grep htt
I get no results --> there is actually nothing running. when I try to start up apahe I still get the same result. when I try to stop it, it says "stopping web server (apache2)... httpd (no pid file) not running.
I am kind of lost there..

Cheers

Riganta

Last edited by riganta; 12-18-2008 at 05:34 AM.
 
Old 12-18-2008, 09:52 AM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,107

Rep: Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720
Quote:
Originally Posted by riganta View Post
how can I simply find out what is taking my port 80 and kill it in my VM ?
I ran a test and configured apache to run on port 443. My Web Server started without any problem. As soon as i put port 80 i get the same error message.
I ran ps -ef | grep htt as advised by TB0ne but i didn't get any result at all. There is nothing that seems to be running at all on port 80.
Well, SOMETHING is running on port 80, obviously. It's hard to say what, since you don't say what other services are running on the box. Did someone install Tomcat/Resin, and is it using port 80? Webmin? Really, almost ANY network-enabled service could be configured to use it, so without knowing what you've got loaded, it's hard to say what it is. Look at the netstat command, and it can give you further information.
 
Old 12-18-2008, 11:35 AM   #5
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
A "netstat -pantu" should show you what is using it.

BTW, I'm moving this to Server as it's not a security issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Networking Conflict Between Virtual Box Network Bridge & OpenSSH Server, Debian Etch TeddyB Linux - Server 4 11-19-2008 06:25 AM
Apache 2 / SSL and virtual host under GNU/Linux Debian Etch - http and https scls19fr Linux - Server 0 10-09-2008 11:11 AM
LXer: Virtual Machine Replication & Failover with VMWare Server & Debian Etch (4.0) LXer Syndicated Linux News 0 08-19-2007 02:50 PM
LXer: Using DSPAM & ClamAV With Postfix (Virtual Users) On Debian Etch LXer Syndicated Linux News 0 08-16-2007 10:20 PM
Debian etch LAMP Server initialdrifteg6 Debian 3 02-05-2006 02:20 PM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration