LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-17-2009, 01:15 PM   #1
bmarien
LQ Newbie
 
Registered: Jan 2009
Posts: 11

Rep: Reputation: 0
LAMP config glitch. dubbel slash in path /var/www//docs/...


Hi,
I'm setting up a debian based lamp server for testing purpose.

Its as debian 2.6.24-etchnhalf.1-686 fresh base install.
used apt-get to add following packages (in given order)

- ssh
- apache2
- mysql-server
- libapache2-mod-php5
- phpmyadmin

Next i created a new virutal site. using a2ensite <name> and a2dissite <name> to disable the default site and enable the newly created one.

PHP is confirmed to be working using phpinfo()
PHPmyAdmin seems to be working fine (/var/www/phpmyadmin)
Mysql is confirmed to be working (imported a big sql file with phpmyadmin)

Now here is where it goes wrong:
I downloaded the latest version of Wordpress and unzipped it in the doc root /var/www/

When loading index.php I get following error:
Code:
Warning: require_once(/var/www//wp-includes/classes.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/wp-load.php on line 43

Fatal error: require_once() [function.require]: Failed opening required '/var/www//wp-includes/classes.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/wp-load.php on line 43
There is double slash in /var/www//wp-includes which i believe is cause by an incorrect relative path setting somewhere, but just can't seem to find where.

Any suggestions are more then welcome. If you need any more info let me know...

Bart
 
Old 01-18-2009, 06:00 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,432

Rep: Reputation: 100Reputation: 100
There are at least to approaches.

1. if mod_rewrite is enabled in apache use that to rewrite double slashes in general. For this you make an .htacces file in /var/www with this content
RewriteCond %{REQUEST_URI} ^(.*)//(.*)$
RewriteRule . %1/%2 [R=301,L]

2. Tae a look at the index.php in WP and see where what is included. Maybe you can find a folder with config files that you can edit to remove the leading slash from the relative path..

Hope this helps
J

(i didn't test the rewrite thing but I think it should work lie that)

Last edited by j-ray; 01-18-2009 at 06:02 AM. Reason: typos
 
Old 01-18-2009, 10:08 AM   #3
bmarien
LQ Newbie
 
Registered: Jan 2009
Posts: 11

Original Poster
Rep: Reputation: 0
Aarg, can't believe it. i didn't cp over all the files i needed, Shame on me.

Thanks for the help guys


This one can be closed
 
  


Reply

Tags
apache2, debian, path, php5, relative


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
URGENT: Apache Server: Directory index forbidden by rule: /aa/www/default/docs/ rrose Linux - Software 1 03-10-2008 08:41 PM
Moving /var/www/ 2-tone-joe Linux - Server 2 12-01-2007 01:27 PM
VSFTPD /var/www mmethe Linux - Software 2 05-10-2005 04:37 AM
help in /var/www/html/!! chidomen Linux - Newbie 4 01-13-2005 11:02 AM
thanks boss....... now i don't have a /var/www joesbox General 4 11-08-2003 01:38 AM


All times are GMT -5. The time now is 12:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration