Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 08-24-2011, 12:49 PM   #1
Registered: Jan 2004
Posts: 112

Rep: Reputation: 1
kickstart slow to initialize

I'm kickstarting a few servers over nfs and have found that it is slow to get going.

I provide all the network information via the boot: prompt and point it at the kickstart file. Once everything gets started eth0 is configured and it reaches out to the nfs server to get its information.

This works. However, the transfer of /mnt/stage2/install.img to /tmp takes ages. Easily about 15 minutes. Once the transfer is complete the install goes rapidly. All the packages are sent over in short order.

What would be causing the insane slowdown at the beginning of the process? I was thinking it might be a difference in NFS versions since I'm kickstarting RHEL6 from an RHEL5 NFS server. If that's the case, is there an option I can pass to force the correct version?
Old 09-16-2011, 10:15 AM   #2
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris
Posts: 71

Rep: Reputation: 2
I would think that once the server and client decide on a version to use then the transfer would just proceed normally. I would suggest using wireshark on the server side to see what is happening during the transfer.
You could also try specifying the version to use for your stage2 like:


At least, I think that's how it's supposed to go.
Old 02-14-2012, 11:28 AM   #3
Registered: Jan 2004
Posts: 112

Original Poster
Rep: Reputation: 1
The issues is that I'm loading the initial boot environment from my workstation over the WAN to our remote systems. There aren't any configuration issues at play here.


installation, kickstart

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kickstart Error Error opening kickstart file (null): bad address Latitude Linux - Networking 0 06-03-2009 12:20 PM
Help: Initialize pthread_cond_t jaepi Programming 1 09-20-2007 02:22 AM
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 01:17 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM
RH8 vs. W2k - Slow, slow, slow zerojosh Linux - Software 2 06-30-2003 08:19 PM

All times are GMT -5. The time now is 01:56 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration