LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 10-01-2007, 02:08 PM   #1
sj_johney
LQ Newbie
 
Registered: Mar 2007
Distribution: Redhat
Posts: 17
Blog Entries: 1

Rep: Reputation: 0
Unhappy Kickstart Configurator Problem - Red Hat Enterprise Linux server 5


Hi all,

I have a server running Red Hat Enterprise Linux Server 5. I was trying to prepare a kickstart file using the Kickstart configurator, and when I come to the "package selection" part, I get a error message "Package Selection is disabled due to problems downloading package information"

Any Idea, why I get this message?

Thank you all....

Regards
Johney
 
Old 10-02-2007, 04:33 PM   #2
thomascameron
LQ Newbie
 
Registered: Oct 2007
Location: Austin, Texas
Distribution: Red Hat Enterprise Linux
Posts: 5

Rep: Reputation: 0
re: Kickstart Configurator Problem - Red Hat Enterprise Linux server 5

Quote:
Originally Posted by sj_johney View Post
Hi all,

I have a server running Red Hat Enterprise Linux Server 5. I was trying to prepare a kickstart file using the Kickstart configurator, and when I come to the "package selection" part, I get a error message "Package Selection is disabled due to problems downloading package information"

Any Idea, why I get this message?

Thank you all....

Regards
Johney
I am guessing that the system is not registered to RHN or to your local Satellite server, right?

What it is telling you is that it is looking for repository information and you have no repositories defined. You can either register the system with RHN or Satellite to access repo info through the yum-rhn-plugin, or create a rhel.repo file in /etc/yum.repos.d that looks something like this:

[server]
name=server
baseurl=http://server.yourcompany.com/path/to/Server
gpgcheck=1
enabled=1

[vt]
name=vt
baseurl=http://server.yourcompany.com/path/to/VT
gpgcheck=1
enabled=1

[cluster]
name=cluster
baseurl=http://server.yourcompany.com/path/to/Cluster
gpgcheck=1
enabled=1

[cluster]
name=clusterstorage
baseurl=http://server.yourcompany.com/path/to/ClusterStorage
gpgcheck=1
enabled=1

Obviously, you will substitute server.yourcompany.com with a server in your organization, and /path/to/blah with the path to the location into which you copied the install media.

Hope this helps
Thomas Cameron, RHCE, RHCI, CNE, MCSE, MCT
 
Old 10-06-2007, 05:55 AM   #3
sj_johney
LQ Newbie
 
Registered: Mar 2007
Distribution: Redhat
Posts: 17
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Hello Thomas Cameron,

You were right, I have not registered to RHN... I will try out your solution. Thank you very much..

Regards
Johney
 
Old 02-13-2008, 02:06 AM   #4
rado_dimitrov
LQ Newbie
 
Registered: Feb 2008
Posts: 3

Rep: Reputation: 0
I have the same problem, done as you said, Thomas, but nothing...
Johney, did you got any success?

Regards,
Rado
 
Old 12-19-2009, 08:57 PM   #5
onlybhanu
LQ Newbie
 
Registered: Oct 2009
Posts: 1

Rep: Reputation: 0
Unhappy Help with KS

Hi,

I am facing problem with the kickstart configuration. When i use system-config-kicstart. A new window is opened but package is disabled and popping error as Package selection is disabled due to problems downloading package informaiton. when i use system-config-packages. I can see the package information but in kickstart package selection is disabled. I think problem is with problem repository that i have created. Please check the steps that are given below


I copied whole rhel dvd into /var/ftp/rhel.
i copied comps-rhel5-server-core.xml and saved in /var/ftp/rhel/Server
i copied comps-rhel5-vt.xml and saved in /var/ftp/rhel/VT
I coped comps-rhel5-cluster.xml and saved in /var/ftp/rhel/Cluster
I coped comps-rhel5-cluster-st.xml and saved in /var/ftp/rhel/ClusterStorage

I removed the repodata direcotry from Server, VT, Cluster and ClusterStorage

# cd /var/ftp/rhel/Server/
# createrepo -g comps-rhel5-server-core.xml /var/ftp/rhel/Server/
# cd /var/ftp/rhel/VT
# createrepo -g comps-rhel5-server-vt.xml /var/ftp/rhel/VT
# cd /va/ftp/rhel/Cluster
# createrepo -g comps-rhel5-cluster.xml /var/ftp/rhel/Cluster
# cd /var/ftp/rhel/ClusterStorage
# createrepo -g comps-rhel5cluster-st.xml /var/ftp/rhel/ClusterStorage

Repository is created

# vi /etc/yum.repo.d/yum.repo

[Server]
name=Server
baseurl=ftp://192.168.0.120/rhel5/Server
enabled=1
gpgcheck=0

[VT]
name=Virtulization
baseurl=ftp://192.168.0.120/rhel5/VT
enabled=1
gpgcheck=0

[Cluster]
name=Cluster
baseurl=ftp://192.168.0.120/rhel5/Cluster
gpgcheck=0
enalbled=1

[ClusterStorage]
name=ClusterStorage
baseurl=ftp://192.168.0.120/rhel5/ClusterStorage/
gpgcheck=0
enalbled=1

# yum clean all
# yum update

There is no point if we enable gpgcheck=1 because i dont have license and I think we have to make some changes in comps-rhel5-server-core.xml
 
Old 12-19-2009, 09:00 PM   #6
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,043

Rep: Reputation: 83
You might try using the kickstart file from root. I believe that is anacondaks.cfg or something like that. It will be autofilled with the options chosen during the server setup.

Just as an alternative.
 
Old 04-20-2012, 01:42 AM   #7
k3v1n
LQ Newbie
 
Registered: Apr 2012
Posts: 1

Rep: Reputation: Disabled
Packages not displayed in system-config-restart

Change the repo id of your .repo file to the redhat default name as
[rhel-debuginfo]
name=anything
baseurl=protocol://ipaddress/pathtorpms
enabled=1
 
Old 04-22-2012, 10:47 AM   #8
pantdk
Member
 
Registered: Oct 2011
Posts: 204
Blog Entries: 3

Rep: Reputation: 15
i think just try this one

# vi /etc/yum.repo.d/yum.repo

[Server]
name=Server
baseurl=ftp://192.168.0.120/rhel5/Server
gpgcheck=0

[VT]
name=Virtulization
baseurl=ftp://192.168.0.120/rhel5/VT
gpgcheck=0

[Cluster]
name=Cluster
baseurl=ftp://192.168.0.120/rhel5/Cluster
gpgcheck=0


[ClusterStorage]
name=ClusterStorage
baseurl=ftp://192.168.0.120/rhel5/ClusterStorage/
gpgcheck=0


# yum clean all
#yum list
# yum update
 
  


Reply

Tags
enterprise, kickstart, redhat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I have problem FTP Server On Red Hat Enterprise 5 thana4748 Linux - Server 2 08-01-2007 10:18 AM
Problem with Red Hat Enterprise Linux 3 silvertype Red Hat 4 02-12-2007 09:04 AM
Red hat linux enterprise...booting problem raj_deep2k1 Linux - General 4 01-27-2006 11:10 PM
red hat enterprise linux 3.0 booting problem cool123 Linux - Software 3 01-10-2006 03:48 AM
Red Hat Enterprise Linux 3 web server? Superfrk Linux - Enterprise 1 06-27-2004 01:11 AM


All times are GMT -5. The time now is 08:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration