LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Kickstart Configurator Problem - Red Hat Enterprise Linux server 5 (http://www.linuxquestions.org/questions/linux-server-73/kickstart-configurator-problem-red-hat-enterprise-linux-server-5-a-588682/)

sj_johney 10-01-2007 03:08 PM

Kickstart Configurator Problem - Red Hat Enterprise Linux server 5
 
Hi all,

I have a server running Red Hat Enterprise Linux Server 5. I was trying to prepare a kickstart file using the Kickstart configurator, and when I come to the "package selection" part, I get a error message "Package Selection is disabled due to problems downloading package information"

Any Idea, why I get this message?

Thank you all....

Regards
Johney

thomascameron 10-02-2007 05:33 PM

re: Kickstart Configurator Problem - Red Hat Enterprise Linux server 5
 
Quote:

Originally Posted by sj_johney (Post 2909622)
Hi all,

I have a server running Red Hat Enterprise Linux Server 5. I was trying to prepare a kickstart file using the Kickstart configurator, and when I come to the "package selection" part, I get a error message "Package Selection is disabled due to problems downloading package information"

Any Idea, why I get this message?

Thank you all....

Regards
Johney

I am guessing that the system is not registered to RHN or to your local Satellite server, right?

What it is telling you is that it is looking for repository information and you have no repositories defined. You can either register the system with RHN or Satellite to access repo info through the yum-rhn-plugin, or create a rhel.repo file in /etc/yum.repos.d that looks something like this:

[server]
name=server
baseurl=http://server.yourcompany.com/path/to/Server
gpgcheck=1
enabled=1

[vt]
name=vt
baseurl=http://server.yourcompany.com/path/to/VT
gpgcheck=1
enabled=1

[cluster]
name=cluster
baseurl=http://server.yourcompany.com/path/to/Cluster
gpgcheck=1
enabled=1

[cluster]
name=clusterstorage
baseurl=http://server.yourcompany.com/path/to/ClusterStorage
gpgcheck=1
enabled=1

Obviously, you will substitute server.yourcompany.com with a server in your organization, and /path/to/blah with the path to the location into which you copied the install media.

Hope this helps
Thomas Cameron, RHCE, RHCI, CNE, MCSE, MCT

sj_johney 10-06-2007 06:55 AM

Hello Thomas Cameron,

You were right, I have not registered to RHN... I will try out your solution. Thank you very much..

Regards
Johney

rado_dimitrov 02-13-2008 03:06 AM

I have the same problem, done as you said, Thomas, but nothing...
Johney, did you got any success?

Regards,
Rado

onlybhanu 12-19-2009 09:57 PM

Help with KS
 
Hi,

I am facing problem with the kickstart configuration. When i use system-config-kicstart. A new window is opened but package is disabled and popping error as Package selection is disabled due to problems downloading package informaiton. when i use system-config-packages. I can see the package information but in kickstart package selection is disabled. I think problem is with problem repository that i have created. Please check the steps that are given below


I copied whole rhel dvd into /var/ftp/rhel.
i copied comps-rhel5-server-core.xml and saved in /var/ftp/rhel/Server
i copied comps-rhel5-vt.xml and saved in /var/ftp/rhel/VT
I coped comps-rhel5-cluster.xml and saved in /var/ftp/rhel/Cluster
I coped comps-rhel5-cluster-st.xml and saved in /var/ftp/rhel/ClusterStorage

I removed the repodata direcotry from Server, VT, Cluster and ClusterStorage

# cd /var/ftp/rhel/Server/
# createrepo -g comps-rhel5-server-core.xml /var/ftp/rhel/Server/
# cd /var/ftp/rhel/VT
# createrepo -g comps-rhel5-server-vt.xml /var/ftp/rhel/VT
# cd /va/ftp/rhel/Cluster
# createrepo -g comps-rhel5-cluster.xml /var/ftp/rhel/Cluster
# cd /var/ftp/rhel/ClusterStorage
# createrepo -g comps-rhel5cluster-st.xml /var/ftp/rhel/ClusterStorage

Repository is created

# vi /etc/yum.repo.d/yum.repo

[Server]
name=Server
baseurl=ftp://192.168.0.120/rhel5/Server
enabled=1
gpgcheck=0

[VT]
name=Virtulization
baseurl=ftp://192.168.0.120/rhel5/VT
enabled=1
gpgcheck=0

[Cluster]
name=Cluster
baseurl=ftp://192.168.0.120/rhel5/Cluster
gpgcheck=0
enalbled=1

[ClusterStorage]
name=ClusterStorage
baseurl=ftp://192.168.0.120/rhel5/ClusterStorage/
gpgcheck=0
enalbled=1

# yum clean all
# yum update

There is no point if we enable gpgcheck=1 because i dont have license and I think we have to make some changes in comps-rhel5-server-core.xml

jstephens84 12-19-2009 10:00 PM

You might try using the kickstart file from root. I believe that is anacondaks.cfg or something like that. It will be autofilled with the options chosen during the server setup.

Just as an alternative.

k3v1n 04-20-2012 02:42 AM

Packages not displayed in system-config-restart
 
Change the repo id of your .repo file to the redhat default name as
[rhel-debuginfo]
name=anything
baseurl=protocol://ipaddress/pathtorpms
enabled=1

pantdk 04-22-2012 11:47 AM

i think just try this one

# vi /etc/yum.repo.d/yum.repo

[Server]
name=Server
baseurl=ftp://192.168.0.120/rhel5/Server
gpgcheck=0

[VT]
name=Virtulization
baseurl=ftp://192.168.0.120/rhel5/VT
gpgcheck=0

[Cluster]
name=Cluster
baseurl=ftp://192.168.0.120/rhel5/Cluster
gpgcheck=0


[ClusterStorage]
name=ClusterStorage
baseurl=ftp://192.168.0.120/rhel5/ClusterStorage/
gpgcheck=0


# yum clean all
#yum list
# yum update


All times are GMT -5. The time now is 06:14 AM.