LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 06-04-2009, 02:50 AM   #1
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 387

Rep: Reputation: 38
kickstart "can't have the end before the start!"


I am getting this Python error from Kickstart with a ks file containing [currently]

Code:
part /boot --fstype ext2 --size=100 --ondisk=sda
part pv.4 --size=0 --grow --ondisk=sda
volgroup VolGroup00 pv.4
#--pesize=32768 pv.4
logvol / --fstype ext4 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow --maxsize=8192
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=1000 --grow
#--maxsize=1984
logvol /Local --fstype ext3 --name=LogVol02 --vgname=VolGroup00 --size=8192 --grow
I have tried a few variants, as you can see, it doesn't seem to matter. I can't see what the issue it, its looks just like many examples I have seen searching the net for the last 2 hours....

Any advice welcome!

Thanks
 
Old 06-04-2009, 02:55 AM   #2
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 387

Original Poster
Rep: Reputation: 38
Oh I must say I have got it working changing this:

Code:
part pv.4 --size=0 --grow --ondisk=sda
To this:

Code:
part pv.4 --size=30000 --grow --ondisk=sda

But from what I read, this should not be needed.
 
Old 07-27-2012, 05:17 PM   #3
Rogue45
Member
 
Registered: Jun 2012
Posts: 47

Rep: Reputation: Disabled
Does it have anything to do with the %end that should be at the end of the command, pre, and post sections?
 
Old 07-28-2012, 11:39 PM   #4
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 387

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by Rogue45 View Post
Does it have anything to do with the %end that should be at the end of the command, pre, and post sections?
I would give that a look into but I am not working at that company any more and not using Kickstart anywhere now.

Thanks though.
 
  


Reply

Tags
kickstart, lvm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A single regex to match anything with ".aac" or ".mp3" at the end ? lumix Linux - General 9 05-09-2008 02:11 AM
fdisk reports odd "Start "and "End" sectors on single partition eponymous Linux - Software 3 10-01-2007 04:41 PM
sunbird 0.3 does not start, error: Segmentation fault : "$prog" ${1+"$@"} polemon Ubuntu 8 01-08-2007 05:22 AM
have to ping gateway to "kickstart" net connection and routing bPrompter Linux - Networking 0 01-19-2005 03:56 PM
How to start KDE automaticlly without typing "startx" then "startkde" Jonescity Slackware 8 10-29-2004 10:32 PM


All times are GMT -5. The time now is 05:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration