LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-14-2009, 05:58 AM   #1
nidhichandyok
LQ Newbie
 
Registered: Sep 2009
Posts: 6

Rep: Reputation: 0
kernel Panic init killed


my local server is giving an error on startup "Kernel panic not syncing attempted to kill INIT".
when i start the system in rescue mode i found that there is no inttab file present. So can anybody help me how to repair the fedora server bcoz i can't afford to reinstall it.
Thanks.

Last edited by nidhichandyok; 12-14-2009 at 06:01 AM.
 
Old 12-14-2009, 08:44 AM   #2
bhaslinux
Member
 
Registered: Oct 2003
Location: UnitedKingdom
Distribution: Debian Lenny
Posts: 351

Rep: Reputation: 47
Hi,

just these lines

id:3:initdefault:
1:2345:respawn:/sbin/getty 38400 tty1

must be able to fix your issue if there is no inittab
this must take you to console login. From there you can start recovering things
 
Old 12-14-2009, 09:50 AM   #3
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,630

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
We need the lines BEFORE "attempted to kill INIT" to say anything more.
 
Old 12-15-2009, 12:31 AM   #4
nidhichandyok
LQ Newbie
 
Registered: Sep 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Hi bhaslinux,
Thanks for the help. Could u plz tell me that where & how to add these lines.
id:3:initdefault:
1:2345:respawn:/sbin/getty 38400 tty1
 
Old 12-15-2009, 06:26 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
Quote:
Originally Posted by nidhichandyok View Post
Hi bhaslinux,
Thanks for the help. Could u plz tell me that where & how to add these lines.
id:3:initdefault:
1:2345:respawn:/sbin/getty 38400 tty1
Look at /etc/inittab---edit this as root with any text editor.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic not sycning no init found try passing a init= option to the kernel? linus72 Linux - Newbie 2 05-25-2009 07:01 AM
Kernel panic - not syncing: No init found. Try passing init= option to kernel. john_schimandle Linux - Embedded & Single-board computer 3 10-10-2008 09:09 AM
Kernel panic - not syncing: No init found. Try passing init= option to kernel. john_schimandle Linux - Newbie 4 10-09-2008 02:40 AM
Kernel panic - not syncing: No init found. Try passing init= option to kernel ranjithmrk Linux - Newbie 4 08-22-2008 02:33 PM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 03:38 AM


All times are GMT -5. The time now is 01:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration