LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   joomla frontend problem (http://www.linuxquestions.org/questions/linux-server-73/joomla-frontend-problem-709238/)

farid_lmu 03-04-2009 07:43 PM

joomla frontend problem
 
hello

my apache web server(fedora 10) php and mysql server supported by joomla(1.5.9).I created a database and joomla (http://localhost/joomla) supported and configured this database. I put the site name and given email and admin password for that site. joomla also installed nicely. after that by rules I delete the installation folder from the joomla directory. after that when I click in site ( in browser if I write http://localhost/joomla/administrator ) usually I have to see a blank site/page which is ready for all joomla content.But I didn't get anything. In page its written no configuration file found & no installation code available. Exiting .. . I found another cause in that case is: SELinux prevented httpd reading and writing access to http files.. I donno whats the problem in that.

can anyone please give me any idea in that.

thank you in advance.

archangel_617b 03-05-2009 01:51 PM

Quote:

Originally Posted by farid_lmu (Post 3465211)
I found another cause in that case is: SELinux prevented httpd reading and writing access to http files.. I donno whats the problem in that.

can anyone please give me any idea in that.

thank you in advance.

This is a question for... Google!

http://www.google.ca/search?q=SELinu...ient=firefox-a

The first couple hits look like they have answers.

...

I usually have SELinux disabled on my systems. In RedHat / CentOS this is:

System > Administration > Security Level and Firewall

SELinux tab
SELinux Setting: Disalbed

OK

Reboot, done!


No matter your solution, I'm guessing you'll probably have to reinstall Joomla.

- Arch

farid_lmu 03-10-2009 08:17 AM

joomla front end problem
 
Quote:

Originally Posted by archangel_617b (Post 3466090)
This is a question for... Google!

http://www.google.ca/search?q=SELinu...ient=firefox-a

The first couple hits look like they have answers.

...

I usually have SELinux disabled on my systems. In RedHat / CentOS this is:

System > Administration > Security Level and Firewall

SELinux tab
SELinux Setting: Disalbed

OK

Reboot, done!


No matter your solution, I'm guessing you'll probably have to reinstall Joomla.

- Arch

========================================================

Thanks Arch, Thank you very much indeed for your suggestions and tips. I just sort out my problem.

bye

avpy 03-26-2009 06:26 AM

Run httpd_unified permissively
 
1 Go to System > Administration > SELinux Management

2 Once there, select Boolean.

3 Then filter by httpd_unified.

4 Set httpd_unified as active.

This will set the httpd_unified to run permissively, but does not disable SELinux.

K.


All times are GMT -5. The time now is 01:08 AM.