LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-17-2012, 04:26 PM   #1
xenner
Member
 
Registered: Jul 2009
Location: Brisbane
Distribution: RHEL 6.5
Posts: 39

Rep: Reputation: 0
iscsi multipathing - Two NICs, one target, single path problem / question


Hello,

I've been tasked with setting up iscsi on a Red Hat 6.3 server with two NIC's.
The problem is, I only manage the server itself. The SAN config is done by someone in another country, and I'm not entirely sure he's configured it correctly.
Saying that, I'm now doubting my configuration.

Basically, I want to have iscsi set up and going through both NIC's as Active / Active. I've logged in to the iscsi target using CHAPS, and when I run:
iscsiadm -m session
I can see the LUNs presented twice (As I should see no doubt).
When I run multipath -ll I can see:
mpathc (36090a07810c9e830ad091507b0ace1db) dm-9 EQLOGIC,100E-00
size=170G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
|- 1:0:0:0 sdf 8:80 active ready running
`- 2:0:0:0 sdh 8:112 active ready running
mpathb (36090a07810c9282bad09f506b0ac413e) dm-8 EQLOGIC,100E-00
size=450G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
|- 9:0:0:0 sdg 8:96 active ready running
`- 10:0:0:0 sdi 8:128 active ready running


However! Traffic is ONLY going through one NIC though. I can see this on my end.
On the SAN side, the other guy can only see my server logging in from one IP, but twice. Two logins from the one IP.

My question is. Can I force my second NIC to log in to the same iscsi target at the same time? Traditionally, I would get two IP addresses to log in to, from what I've read. And I'd log in to those individually. But this guy insists that this single IP he's given me (For the equalogic setup) is the way it should be done.

Thanks for your assistance community people.

X3N.
 
Old 12-18-2012, 08:53 AM   #2
robertjinx
Member
 
Registered: Oct 2007
Location: Prague, CZ
Distribution: RedHat / CentOS / Ubuntu / SUSE / Debian
Posts: 585

Rep: Reputation: 58
I think in iscsiadm you can also use different adapters for different targets, but depends a lot on you setup and so on.

I might not understand perfectly your setup, so I could be wrong.

Code:
iscsiadm -m discovery [ -hV ] [ -d debug_level ] [-P printlevel] [ -t type -p ip:port -I ifaceN ... [ -l ]
"-I ifaceN" should be eth0 or eth1 or whatever.
 
Old 12-18-2012, 10:40 AM   #3
vahab
Member
 
Registered: Jun 2011
Posts: 56

Rep: Reputation: Disabled
You need to set the policy of multibus for each device in multipathd configuration file.
 
Old 12-18-2012, 07:13 PM   #4
xenner
Member
 
Registered: Jul 2009
Location: Brisbane
Distribution: RHEL 6.5
Posts: 39

Original Poster
Rep: Reputation: 0
Hi,

The multipathd conf file has multibus set. These are active / active.

I have attempted to log in from the secondary interface, using -I option, but this is not allowing me to log in.

After discussing this problem with Dell, it has been advised that I should use their tool, and not native tools. Which, is kind of annoying, as I know that this method should work.

There has to be a way to force iface1 AND iface2 to log in individually.

More suggestions?

Thanks.

X3N
 
Old 12-19-2012, 01:59 AM   #5
robertjinx
Member
 
Registered: Oct 2007
Location: Prague, CZ
Distribution: RedHat / CentOS / Ubuntu / SUSE / Debian
Posts: 585

Rep: Reputation: 58
I would suggest to do a failover test, disconnect the first working network, see if the traffic starts going thru the second one, if not then most probably is a network issue/setup. Maybe missing routes or something like that. When I'm saying a failover test, doesn't mean running manually "ifconfig eth0 down" means manually unplug the network cable from your server.

Besides that I don't know, I would need to be on the box to try ideas
 
Old 12-19-2012, 07:46 PM   #6
xenner
Member
 
Registered: Jul 2009
Location: Brisbane
Distribution: RHEL 6.5
Posts: 39

Original Poster
Rep: Reputation: 0
Hi,

I've done a failover test, and I see traffic going through the other NIC. This was done when I configured the multipathing.

If I had two separate targets, I could log into both, but I only have the one.. Very annoying that I can't make each NIC log into the single target individually.

Another note is: I've now followed Dell's recommendations to install their "software" fail. And it's even slower than the config I set up myself (And this is Dell's recommendations). I have fine write speeds, but between 2 and 10Mb a second reads, which is absolutely terrible.

If anyone's used equallogics config on RHEL 6.2 before against an iscsi target, I'd LOVE to hear what you've done to improve performance from the OS side... As the guy that does the infrastructure swears his gear is configured correctly.

So, I'm still open for suggestions to make both NICs log into one iscsi target without bonding, but using multipath instead (And iscsiadm of course).

Thanks.

X3N
 
  


Reply

Tags
iscsi, multipath, red hat, san


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Iscsi target on Freenas 7 or 8 jefro *BSD 5 01-03-2011 04:39 PM
install livecd to iscsi target aclhkaclhk Linux - Software 1 01-30-2010 06:24 PM
Problem with iscsi Multipathing on RHEL4 v@to Linux - Server 7 12-06-2008 12:27 PM
changes on other iscsi nodes attached to an ext3 iscsi target not being seen sldahlin Linux - Server 1 06-07-2008 02:02 AM
iscsi multipathing with RHELAS 4 Update2 with qlogic troubles f0rmat Red Hat 15 09-02-2006 06:31 PM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration