LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-11-2013, 07:59 AM   #1
knilux
Member
 
Registered: Mar 2012
Location: The Netherlands
Distribution: OpenSuSE
Posts: 42

Rep: Reputation: Disabled
Iscsi does not recognise partition


I am trying to set up an Iscsi server with OpenSUSE 12.2. With Yast you can configure the whole thing with the Iscsi-Target menu. I managed to get a working situation, but was not satisfied with the partitioning (wanted to add LVM), so I started over again from scratch.
The weird thing is that now Iscsi can not see the available partition anymore.

I recreated a separate (non-LVM) partition for Iscsi again and deleted everything on it. No mountpoints added, only filesystem type Ext4, which I used in the test before. I even used "shred" to delete everything on that partition.
When I do
Code:
"iscsiadm -m discovery"
it gives me the error:
Code:
"iscsiadm: no records found!"
I assume this is because the partition is not there.
Code:
"iscsiadm -m session"
replies with:
Code:
"iscsiadm: no active sessions".
Which sounds logical to me.

In the first test I could find the path of the blockdevice and it's size in dmesg. In the second test there is no info there, except this:
Code:
[   24.086215] iSCSI Enterprise Target Software - version trunk
[   24.086483] iscsi_trgt: Registered io type fileio
[   24.086488] iscsi_trgt: Registered io type blockio
[   24.086492] iscsi_trgt: Registered io type nullio
[   24.417461] Loading iSCSI transport class v2.0-870.
[   24.434670] iscsi: registered transport (tcp)
[   24.483607] iscsi: registered transport (iser)
I have been Googling a lot, but can not find any useful info on this topic.

So the question is: why does Iscsi not recognise the partition anymore? What commands can I use to debug here? I am completely run of ideas at the moment.

Thanks for any help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help!The iscsi can't find partition niver Linux - Server 3 12-14-2012 02:14 AM
[SOLVED] Debian installer doesn't recognise existing encrypted partition saivnoba Debian 3 02-25-2012 08:08 AM
CentOS 5.3 - how can I set up a partition as an iscsi tartget slinx Red Hat 2 03-18-2010 11:00 AM
test26.s doesn't recognise DVD drive, other kernels won't recognise HDD v@ny@ Slackware - Installation 15 05-31-2007 06:03 AM
Linux won't recognise partition table but OS-X and M$ do njbailey Linux - Kernel 6 10-31-2006 02:38 PM


All times are GMT -5. The time now is 02:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration