LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-31-2012, 07:05 AM   #1
shayno90
Member
 
Registered: Oct 2009
Distribution: Debian Lenny 2.6.26 Ubuntu Lucid Lynx 10.04 Windows 7
Posts: 180
Blog Entries: 2

Rep: Reputation: 21
Invalid domain, status bounced using RT, POSTFIX


Error message from /var/log/mail.log:

Aug 25 09:58:56 MAILSRV01 postfix/smtp[2591]: 000B51D5366: to=<user@kite.it>, relay=mx.kite.it[62.149.128.140]:25, delay=0.99, delays=0.07/0/0.18/0.74, dsn=5.1.0, status=bounced (host mx.kite.it[62.149.128.140] said: 550 5.1.0 tMyu1j02j2zd5X801Myv94 dominio non valido / invalid domain (in reply to MAIL FROM command))

Sending am email from our own mail account, user@pum.ie via Request Tracker to user@kite.it fails everytime but without RT, it can be sent!

The mail server on the destination side did some checks and they can see no issue.

An email could be send correctly up until a month ago. I checked the alias and hostname plus email addresses and they are correct.

mail.pum.ie for example is set

Any ideas?

Last edited by shayno90; 08-31-2012 at 09:20 AM.
 
Old 08-31-2012, 07:16 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
public DNS lookups on pum.ie and mail.pum.ie return no IP addresses.
 
Old 08-31-2012, 08:39 AM   #3
shayno90
Member
 
Registered: Oct 2009
Distribution: Debian Lenny 2.6.26 Ubuntu Lucid Lynx 10.04 Windows 7
Posts: 180
Blog Entries: 2

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by acid_kewpie View Post
public DNS lookups on pum.ie and mail.pum.ie return no IP addresses.
I have changed the domain and mail server names to keep company anonymity.

A DNS lookup returns the appropriate mail server/host/domain name.

The main issue is using RT to send a mail, as postfix works correctly without RT.
 
Old 08-31-2012, 08:40 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
Hmm, use "domain.com" or something obvious next time huh?

so what IS the domain the mail is being sent with? maybe it's defaulting to localhost.localdomain or something, as the remote server clearly doesn't like the from address on the email.

Last edited by acid_kewpie; 08-31-2012 at 08:44 AM.
 
Old 08-31-2012, 09:53 AM   #5
shayno90
Member
 
Registered: Oct 2009
Distribution: Debian Lenny 2.6.26 Ubuntu Lucid Lynx 10.04 Windows 7
Posts: 180
Blog Entries: 2

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by acid_kewpie View Post
Hmm, use "domain.com" or something obvious next time huh?

so what IS the domain the mail is being sent with? maybe it's defaulting to localhost.localdomain or something, as the remote server clearly doesn't like the from address on the email.

Server where RT is hosted:

cat /etc/hosts
127.0.0.1 localhost

192.168.10.40 srv02.company.ie srv02

Postfix details:
cat /etc/postfix/main.cf
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no


myhostname = srv02.company.ie
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = srv02.company.ie, localhost.company.ie, localhost
relayhost = 192.168.10.1
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
-------------------------------------------------

cat /etc/mailname
srv02.company.ie

I am not sure if how to edit RT into accepting the email address which is causing the problem.
The destination mail server accepts the email address normally without RT so need to know where to check in RT for this.
 
Old 08-31-2012, 09:55 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
but the SMTP issue is on the remote SMTP server, mx.kite.ie, not on your server. It is unable to validate the address so not allowing your postfix box to pass it to it.

RT is not not accepting the email, RT will have no involvement in that stage in the slightest. Surely it's creating an email with an illegal FROM header?
 
Old 08-31-2012, 10:23 AM   #7
shayno90
Member
 
Registered: Oct 2009
Distribution: Debian Lenny 2.6.26 Ubuntu Lucid Lynx 10.04 Windows 7
Posts: 180
Blog Entries: 2

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by acid_kewpie View Post
but the SMTP issue is on the remote SMTP server, mx.kite.ie, not on your server. It is unable to validate the address so not allowing your postfix box to pass it to it.

RT is not not accepting the email, RT will have no involvement in that stage in the slightest. Surely it's creating an email with an illegal FROM header?
From header on RT ticket:
-----------------------------------------
Subject: [company #276] Report (2012)
From: "username via RT" <user1@company.ie>
Reply-To: user1@company.ie
In-Reply-To:
References: <RT-Ticket-276@company.ie>
Message-ID: <rt-3.8.4-260-1346133-669.276-13-0@company.ie>
Precedence: bulk
X-RT-Loop-Prevention: company
RT-Ticket: company #276
Managed-by: RT 3.8.4 (http://www.bestpractical.com/rt/)
RT-Originator: user1@company.ie
To: user10@kite.it, user11@kite.it, user12@kite.it
MIME-Version: 1.0
X-RT-Original-Encoding: utf-8
Date: Fri, 29 Aug 2012 10:10:53 +0000
RT-Attachment: 2746/2213/5094
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 8bit
--------------------------------------------------------------

The email address used in the "From" header is correct but whatever way RT sends it, the target mail server does not like it considering it as an invalid domain.
 
Old 08-31-2012, 11:20 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
well compare and contrast. Grab an actual email as it leaves postfix sent from RT and another from a client that works.
 
Old 09-03-2012, 06:06 AM   #9
shayno90
Member
 
Registered: Oct 2009
Distribution: Debian Lenny 2.6.26 Ubuntu Lucid Lynx 10.04 Windows 7
Posts: 180
Blog Entries: 2

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by acid_kewpie View Post
well compare and contrast. Grab an actual email as it leaves postfix sent from RT and another from a client that works.
Email sent from webmail successfully:
Sep 3 10:53:36 srv02 postfix/smtp[30645]: 6BCB11D62: to=<user@company.it>, relay=mx.company.it[xx.149.128.160]:25, delay=1.5, delays=0.01/0/0.18/1.3, dsn=2.0.0, status=sent (250 2.0.0 uata1j0282zd5X801atbuA mail accepted for delivery)
Sep 3 10:53:36 srv02 postfix/smtp[30645]: 6BCB11D62: to=<user@company.it>, relay=mx.company.it[xx.149.128.160]:25, delay=1.5, delays=0.01/0/0.18/1.3, dsn=2.0.0, status=sent (250 2.0.0 uata1j0282zd5X801atbuA mail accepted for delivery)
Sep 3 10:53:36 srv02 postfix/smtp[30645]: 6CB11D62: to=<user@company.it>, relay=mx.company.it[xx.149.128.160]:25, delay=1.5, delays=0.01/0/0.18/1.3, dsn=2.0.0, status=sent (250 2.0.0 uata1j0282zd5X801atbuA mail accepted for delivery)

Email sent via RT unsuccessfully:
Sep 3 10:46:04 srv02 postfix/smtp[29727]: 315E11D5362: to=<user@company.it>, relay=mx.company.it[xx.149.128.151]:25, delay=1.1, delays=0.09/0/0.18/0.79, dsn=5.1.0, status=bounced (host mx.company.it[xx.149.128.151] said: 550 5.1.0 uam21j01W2zd5X801am2Ll dominio non valido / invalid domain (in reply to MAIL FROM command))
Sep 3 10:46:04 srv02 postfix/smtp[29727]: 315E11D5362: to=<user@company.it>, relay=mx.company.it[xx.149.128.151]:25, delay=1.1, delays=0.09/0/0.18/0.79, dsn=5.1.0, status=bounced (host mx.company.it[xx.149.128.151] said: 550 5.1.0 uam21j01W2zd5X801am2Ll dominio non valido / invalid domain (in reply to MAIL FROM command))
Sep 3 10:46:04 srv02 postfix/smtp[29727]: 315E11D5362: to=<user@company.it>, relay=mx.company.it[xx.149.128.151]:25, delay=1.1, delays=0.09/0/0.18/0.79, dsn=5.1.0, status=bounced (host mx.company.it[xx.149.128.151] said: 550 5.1.0 uam21j01W2zd5X801am2Ll dominio non valido / invalid domain (in reply to MAIL FROM command))
 
Old 09-03-2012, 06:47 AM   #10
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
right, but those are just logs. logs which don't show the FROM header...
 
Old 09-03-2012, 08:16 AM   #11
shayno90
Member
 
Registered: Oct 2009
Distribution: Debian Lenny 2.6.26 Ubuntu Lucid Lynx 10.04 Windows 7
Posts: 180
Blog Entries: 2

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by acid_kewpie View Post
right, but those are just logs. logs which don't show the FROM header...
Email via webmail:

From : user@company.ie
Subject : test email
To : user1@company.it, user2 <user2@company.it>, user3 <user3@company.it>
Mon, Sep 03, 2012 11:53 AM

Email via RT:

Subject: [company #216] test email
From: "username via RT" <user@company.ie>
Reply-To: user@company.ie
In-Reply-To:
References: <RT-Ticket-216@company.ie>
Message-ID: <rt-3.8.4-255-169161-803.216-13-0@company.ie>
Precedence: bulk
X-RT-Loop-Prevention: company
RT-Ticket: company #216
Managed-by: RT 3.8.4 (http://www.bestpractical.com/rt/)
RT-Originator: rtuser@company.ie
To: user1@company.it, user2@company.it, user3@company.it
MIME-Version: 1.0
X-RT-Original-Encoding: utf-8
Date: Mon, 3 Sep 2012 10:46:01 +0000
 
Old 09-04-2012, 05:41 AM   #12
shayno90
Member
 
Registered: Oct 2009
Distribution: Debian Lenny 2.6.26 Ubuntu Lucid Lynx 10.04 Windows 7
Posts: 180
Blog Entries: 2

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by acid_kewpie View Post
right, but those are just logs. logs which don't show the FROM header...
Successful email from RT to gmail:

Delivered-To: user@gmail.com
Received: by 10.68.130.226 with SMTP id oh2csp545pbb;
Tue, 4 Sep 2012 03:27:24 -0700 (PDT)
Received: by 10.216.64.79 with SMTP id b57mr1569wed.31.1346754443876;
Tue, 04 Sep 2012 03:27:23 -0700 (PDT)
Return-Path: <user@srv.company.ie>
Received: from srv.company.ie (mail.company.ie. [XX.XXX.XXX.XXX])
by mx.google.com with ESMTP id bc8si22448wib.35.2012.09.04.03.27.23;
Tue, 04 Sep 2012 03:27:23 -0700 (PDT)

Subject: [company #216] email
From: "username via RT" <user@company.ie>
Reply-To: user@company.ie
In-Reply-To:
References: <RT-Ticket-216@company.ie>
Message-ID: <rt-3.8.4-21-1340-56.26-13-0@company.ie>
Precedence: bulk
X-RT-Loop-Prevention: company
RT-Ticket: company #216
Managed-by: RT 3.8.4 (http://www.bestpractical.com/rt/)
RT-Originator: user@company.ie
To: user@gmail.com
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset="utf-8"
X-RT-Original-Encoding: utf-8
Date: Tue, 4 Sep 2012 10:27:20 +0000

Still an issue with sending mail from RT to company.it mailbox though.

Last edited by shayno90; 09-04-2012 at 09:24 AM.
 
Old 09-05-2012, 08:33 AM   #13
shayno90
Member
 
Registered: Oct 2009
Distribution: Debian Lenny 2.6.26 Ubuntu Lucid Lynx 10.04 Windows 7
Posts: 180
Blog Entries: 2

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by acid_kewpie View Post
right, but those are just logs. logs which don't show the FROM header...
Any useful information in the headers I provided acid_kewpie?

I would like to know what exactly is the issue in order to inform the destination mail server admin what to change.
 
Old 09-05-2012, 09:00 AM   #14
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
TBH, I'm out of ideas from the info provided. 550 in the RCPT context says the mailbox is unavailable, despite the textual description suggesting it's a reverse lookup failure or something http://www.greenend.org.uk/rjk/tech/smtpreplies.html
 
  


Reply

Tags
domain, invalid, postfix, request, tracker


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Postfix as a mail delivery server fails (status bounced loops back to myself) Larry James Linux - Server 8 07-18-2011 06:42 PM
postfix - smtpd_recipient_restrictions & invalid sender domain compused Linux - Newbie 2 04-17-2010 07:34 AM
Postfix: Invalid domain nukoso Linux - Server 2 02-11-2008 12:57 PM
status=bounced in Postfix/Cyrus on Ubuntu mailserver setup thomasJohansen Linux - Server 7 01-07-2007 11:07 AM
Problem w/ Cyrus Status=Bounced Signal 11 davidswanson1 Linux - Server 0 12-21-2006 06:24 PM


All times are GMT -5. The time now is 06:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration