LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   internet access via proxy server (http://www.linuxquestions.org/questions/linux-server-73/internet-access-via-proxy-server-804675/)

salimshahzad 04-28-2010 01:06 AM

internet access via proxy server
 
centos 5.4 distro using on remote machine

i have remote site where internet access given via squid proxy. so when we enter in browser it start working internet fine.

but on command line(bash shell prompt terminal) like wget,ping,nslookup,traceroute etc these commands does not work.

advise where what work around needed?

barshani 04-28-2010 01:36 AM

you should try the following command in shell prompt

# export http_proxy=http://proxyServer-IP:port/

then try

# wget http://site name

If any issue please check with DNS resolving. /etc/resolv.conf

for permanent you should add this (export http_proxy=http://proxyServer-IP:port/ ) in /etc/rc.local or /etc/profile

salimshahzad 04-28-2010 04:28 AM

/etc/profile i have edit it enter details
/etc/resolv.conf i update all local and global dns

but still commands like ping,traceroute,netstat,ssh outside world not working i want pass everything through proxy

wget start working now

suggest for other commands of linux what to do?

barshani 04-28-2010 04:39 AM

Just check your firewall status.

# service iptables status

# iptables -L

salimshahzad 04-28-2010 07:24 AM

firewall is stop disable and no rules made also

barshani 04-28-2010 11:51 AM

is your DNS server configured local or Public.
what is the entry in /etc/resolv.conf

divyashree 04-28-2010 01:12 PM

Quote:

Originally Posted by salimshahzad (Post 3950146)
centos 5.4 distro using on remote machine

i have remote site where internet access given via squid proxy. so when we enter in browser it start working internet fine.

but on command line(bash shell prompt terminal) like wget,ping,nslookup,traceroute etc these commands does not work.

advise where what work around needed?

You try onething ,

Goto system -> Preferences -> Nework proxy -> Manual Proxy configuration
and give the proxy server IP and port in HTTP Proxy section .

Try it then post the result . It may work as I've not tried ..


All times are GMT -5. The time now is 04:43 AM.