LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Installing pcre-6* library (http://www.linuxquestions.org/questions/linux-server-73/installing-pcre-6%2A-library-803964/)

miscel 04-24-2010 12:57 PM

Installing pcre-6* library
 
Hello,

I added some repos and updated system. End of this action, pcre-7* installed on system. I have to install pcre-6* for another package installing install but errors occured.

How to upgrade pcre-7* to pcre-6*?

Thanks

Software : Centos 5.4

Error Message :

--
Transaction Check Error:
package pcre-7.8-1.jason.1.x86_64 (which is newer than pcre-6.6-2.el5_1.7.i386) is already installed
file /usr/share/man/man1/pcregrep.1.gz from install of pcre-6.6-2.el5_1.7.i386 conflicts with file from package pcre-7.8-1.jason.1.x86_64
file /usr/share/man/man1/pcretest.1.gz from install of pcre-6.6-2.el5_1.7.i386 conflicts with file from package pcre-7.8-1.jason.1.x86_64

--

knudfl 04-25-2010 12:06 AM

Welcome to LQ.

QUOTE: ""I added some repos and updated system.""

.......... That is dangerous business !
It is not possible to have alien repo files enabled,
and then run updates. EPEL should be OK, all other
are to be used only temporary, for special packages.
( Or for updating one package at a time.)

You will have to remove the /etc/yum.repos.d/utterramblings.repo
( or disable it ). I guess, the "jason" pcre comes from that.
http://www.jasonlitka.com/yum-repository/ → utterramblings....

yum remove pcre* ( or # rpm -e --nodeps pcre*
(if yum can't) to remove the odd version.)

And then you can install, what you need.
(( Jason packages ))


All times are GMT -5. The time now is 04:55 PM.