LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Installing 32 bit RPMs on 64 bit Linux conflicts with 64 bit packages (http://www.linuxquestions.org/questions/linux-server-73/installing-32-bit-rpms-on-64-bit-linux-conflicts-with-64-bit-packages-897990/)

gheibia 08-18-2011 02:24 AM

Installing 32 bit RPMs on 64 bit Linux conflicts with 64 bit packages
 
Hi,

I'm using a 64 bit Linux server (OEL 6.1):

[root@dbserver ~]# uname -r
2.6.32-100.34.1.el6uek.x86_64


I was trying to install Oracle Database on this server that I realized the installer requires some 32 bit libraries. For instance it was looking for libXp.so.6 which existed under /usr/lib64, but not /usr/lib.
Even when I changed the installation script to look into lib64 for the library, it failed with an error from Java that it needs 32 bit and instead has found 64 bit.

I downloaded a bunch of 32 bit RPM packages and when I tried to install them, I got the error that a newer version of those packages is installed, which is not the case. Cause all previously installed packages are 64 bit. I was wondering why it thinks that 64 bit packages are newer version of 32 bit packages. And is there a way to solve this?

[root@dbserver ~]# rpm -ivh libXp-1.0.0-8.i386.rpm xorg-x11-Mesa-libGL-6.8.2-31.i386.rpm xorg-x11-libs-6.8.2-31.i386.rpm expat-1.95.8-9.i386.rpm libXau-1.0.1-3.1.i386.rpm fontconfig-2.3.94-1.i386.rpm zlib-1.2.1.2-1.i386.rpm freetype-2.1.7-4.i386.rpm
warning: libXp-1.0.0-8.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 4f2a6fd2: NOKEY
Preparing... ########################################### [100%]
package zlib-1.2.3-25.el6.x86_64 (which is newer than zlib-1.2.1.2-1.i386) is already installed
package freetype-2.3.11-6.el6_0.2.x86_64 (which is newer than freetype-2.1.7-4.i386) is already installed
package expat-2.0.1-9.1.el6.x86_64 (which is newer than expat-1.95.8-9.i386) is already installed
package fontconfig-2.8.0-3.el6.x86_64 (which is newer than fontconfig-2.3.94-1.i386) is already installed
package libXau-1.0.5-1.el6.x86_64 (which is newer than libXau-1.0.1-3.1.i386) is already installed
package libXp-1.0.0-15.1.el6.x86_64 (which is newer than libXp-1.0.0-8.i386) is already installed
file /usr/share/man/man1/xmlwf.1.gz from install of expat-1.95.8-9.i386 conflicts with file from package expat-2.0.1-9.1.el6.x86_64
file /usr/share/doc/libXp-1.0.0/ChangeLog from install of libXp-1.0.0-8.i386 conflicts with file from package libXp-1.0.0-15.1.el6.x86_64
file /usr/share/doc/libXp-1.0.0/INSTALL from install of libXp-1.0.0-8.i386 conflicts with file from package libXp-1.0.0-15.1.el6.x86_64
file /usr/share/doc/libXp-1.0.0/COPYING from install of libXp-1.0.0-8.i386 conflicts with file from package libXp-1.0.0-15.1.el6.x86_64
file /usr/share/doc/libXp-1.0.0/AUTHORS from install of libXp-1.0.0-8.i386 conflicts with file from package libXp-1.0.0-15.1.el6.x86_64
file /etc/fonts/fonts.conf from install of fontconfig-2.3.94-1.i386 conflicts with file from package fontconfig-2.8.0-3.el6.x86_64
file /etc/fonts/fonts.dtd from install of fontconfig-2.3.94-1.i386 conflicts with file from package fontconfig-2.8.0-3.el6.x86_64
file /usr/share/man/man1/fc-cache.1.gz from install of fontconfig-2.3.94-1.i386 conflicts with file from package fontconfig-2.8.0-3.el6.x86_64
file /usr/share/man/man1/fc-cat.1.gz from install of fontconfig-2.3.94-1.i386 conflicts with file from package fontconfig-2.8.0-3.el6.x86_64
file /usr/share/man/man1/fc-list.1.gz from install of fontconfig-2.3.94-1.i386 conflicts with file from package fontconfig-2.8.0-3.el6.x86_64
file /usr/share/man/man1/fc-match.1.gz from install of fontconfig-2.3.94-1.i386 conflicts with file from package fontconfig-2.8.0-3.el6.x86_64
file /usr/share/man/man5/fonts-conf.5.gz from install of fontconfig-2.3.94-1.i386 conflicts with file from package fontconfig-2.8.0-3.el6.x86_64


Any suggestion is greatly appreciated.

acid_kewpie 08-18-2011 02:33 AM

install up to date versions of the i386 packages and you should be ok. different *architectures* of the same version will still have the same documentation etc., but not different *versions*.


All times are GMT -5. The time now is 02:03 AM.