LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-03-2012, 02:01 AM   #1
johnhalbert
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Rep: Reputation: Disabled
Installed programs conflict with DNS


So my server was working just fine as of yesterday, but today for some reason DNS is no longer working. I have no idea why and the only change that was made to the server was installing system-config-date and its' dependencies. I'm not familiar with most of these but could any of them be interfering with DNS?


system-config-date.noarch 0:1.8.12-5.el5.centos
GConf2.i386 0:2.14.0-9.el5
ORBit2.i386 0:2.14.3-5.el5
alsa-lib.i386 0:1.0.17-1.el5
atk.i386 0:1.12.2-1.fc6
audiofile.i386 1:0.2.6-5
avahi.i386 0:0.6.16-10.el5_6
avahi-glib.i386 0:0.6.16-10.el5_6
bitstream-vera-fonts.noarch 0:1.10-7
cairo.i386 0:1.2.4-5.el5
cryptsetup-luks.i386 0:1.0.3-8.el5
dbus-glib.i386 0:0.73-10.el5_5
dbus-python.i386 0:0.70-9.el5_4
desktop-file-utils.i386 0:0.10-7
docbook-dtds.noarch 0:1.0-30.1
esound.i386 1:0.2.36-4
fontconfig.i386 0:2.4.1-7.el5
gamin.i386 0:0.1.7-10.el5
gnome-doc-utils.noarch 0:0.8.0-2.fc6
gnome-keyring.i386 0:0.6.0-1.fc6
gnome-mime-data.i386 0:2.4.2-3.1
gnome-mount.i386 0:0.5-3.el5
gnome-python2.i386 0:2.16.0-1.fc6
gnome-python2-bonobo.i386 0:2.16.0-1.fc6
gnome-python2-canvas.i386 0:2.16.0-1.fc6
gnome-python2-gnomevfs.i386 0:2.16.0-1.fc6
gnome-vfs2.i386 0:2.16.2-8.el5
gtk2.i386 0:2.10.4-21.el5_7.7
hal.i386 0:0.5.8.1-62.el5
hicolor-icon-theme.noarch 0:0.9-2.1
hwdata.noarch 0:0.213.26-1.el5
kbd.i386 0:1.12-21.el5
libICE.i386 0:1.0.1-2.1
libIDL.i386 0:0.8.7-1.fc6
libSM.i386 0:1.0.1-3.1
libXcursor.i386 0:1.1.7-1.2
libXext.i386 0:1.0.1-2.1
libXfixes.i386 0:4.0.1-2.1
libXft.i386 0:2.1.10-1.1
libXi.i386 0:1.0.1-4.el5_4
libXinerama.i386 0:1.0.1-2.1
libXrandr.i386 0:1.1.1-3.3
libXrender.i386 0:0.9.1-3.1
libXres.i386 0:1.0.1-3.1
libXt.i386 0:1.0.2-3.2.el5
libart_lgpl.i386 0:2.3.17-4
libbonobo.i386 0:2.16.0-1.1.el5_5.1
libbonoboui.i386 0:2.16.0-1.fc6
libdaemon.i386 0:0.10-5.el5
libglade2.i386 0:2.6.0-2
libgnome.i386 0:2.16.0-6.el5
libgnomecanvas.i386 0:2.14.0-4.1
libgnomeui.i386 0:2.16.0-5.el5
libnotify.i386 0:0.4.2-6.el5
libvolume_id.i386 0:095-14.27.el5_7.1
libwnck.i386 0:2.16.0-4.fc6
notification-daemon.i386 0:0.3.5-9.el5
ntp.i386 0:4.2.2p1-15.el5.centos.1
openjade.i386 0:1.3.2-27
opensp.i386 0:1.5.2-4
pango.i386 0:1.14.9-8.el5.centos.3
pciutils.i386 0:3.1.7-5.el5
pm-utils.i386 0:0.99.3-10.el5.centos
pycairo.i386 0:1.2.0-1.1
pygobject2.i386 0:2.12.1-5.el5
pygtk2.i386 0:2.10.1-12.el5
pygtk2-libglade.i386 0:2.10.1-12.el5
pyorbit.i386 0:2.14.1-3.el5
python-numeric.i386 0:23.7-2.2.2.el5_6.1
rhpl.i386 0:0.194.1-2
scrollkeeper.i386 0:0.3.14-9.el5
sgml-common.noarch 0:0.6.3-18
shared-mime-info.i386 0:0.19-5.el5
startup-notification.i386 0:0.8-4.1
wireless-tools.i386 1:28-2.el5
xml-common.noarch 0:0.6.3-18
xulrunner.i386 0:10.0.3-1.el5_8
yelp.i386 0:2.16.0-29.el5_8
 
Old 04-03-2012, 04:48 AM   #2
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,188
Blog Entries: 4

Rep: Reputation: 219Reputation: 219Reputation: 219
Hello johnhalbert

Kindly provide complete and relevant info which can help us understand and troubleshoot you problem. Just by saying your DNS is not working we can't start guessing about the error. So please be specific about the problem you are facing in your DNS server

post your log messages
Code:
#cat /var/log/messages
tell us about your distro
 
Old 05-06-2012, 06:21 PM   #3
johnhalbert
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
New DNS Record Not Available Publicly?

BIND is giving me some trouble as I just set up a new DNS record for a domain I purchased a day or so ago. I've gone through the setup many times to be sure, but this domain is set up exactly as the others - both in the named.conf and in the .hosts file that I've set up.

When checking at intodns.com there are multiple problems, including warnings about lame servers and a non-existent SOA record. When trying to get DNS information with the host command it says that the servers are unreachable. I have three nameservers, one master and two slaves, and the slaves are not updating apparently as there is no file for this domain in my slaves folder.

I'm very confused why this one would not work as others did. Any suggestions where I can start to troubleshoot this? I'm fairly new to DNS so I'm not sure which direction to go to fix this problem.

I should add this is on a centos 5 server.
 
Old 05-06-2012, 08:19 PM   #4
es0teric
Member
 
Registered: Apr 2007
Distribution: Ubuntu
Posts: 93

Rep: Reputation: 19
Do you see that bind is listening on the right port on your servers? Any bind config files you could provide would be helpful as well.
 
Old 05-06-2012, 09:35 PM   #5
johnhalbert
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
I'm assuming that bind is listening on port 53, all other domains configured on the nameserver are working properly - i.e. I can use the host command to find their records and intodns.com returns everything as OK.

Master named.conf

Code:
options {
        directory "/etc/";
        pid-file "/var/run/named/named.pid";
        recursion no;
        };

logging {
        channel custom {
                file "/var/log/named/named.log";
                print-time yes;
                print-category yes;
                };
        category config         { custom; };
        category notify         { custom; };
        category dnssec         { custom; };
        category general        { custom; };
        category security       { custom; };
        category xfer-out       { custom; };    # zone transfers
        category lame-servers   { custom; };
        };

zone "domain1.com" {
        type master;
        file "/var/named/domain1.com.hosts";
        allow-transfer {
                xxx.xx.xxx.xxx;
                xxx.xx.xxx.xxx;
                xx.x.xx.xxx;
                };
        };

zone "domain2.com" {
        type master;
        file "/var/named/domain2.com.hosts";
        allow-transfer {
                xxx.xx.xxx.xxx;
                xxx.xx.xxx.xxx;
                xx.x.xx.xxx;
                };
        };

zone "domain3.com" {
        type master;
        file "/var/named/domain3.com.hosts";
        allow-transfer {
                xxx.xx.xxx.xxx;
                xxx.xx.xxx.xxx;
                xx.x.xx.xxx;
                };
        };

zone "domain4.com" {
        type master;
        file "/var/named/domain4.com.hosts";
        allow-transfer {
                xxx.xx.xxx.xxx;
                xxx.xx.xxx.xxx;
                xx.x.xx.xxx;
                };
        };
Slave named.conf

Code:
options {
        directory "/etc";
        pid-file "/var/run/named/named.pid";
        recursion no;
        };

zone "domain1.com" {
        type slave;
        file "/var/named/slaves/domain1.com.hosts";
        masters {
                xxx.xxx.xxx.xxx;
                xxx.xxx.xx.xx;
                };
        };

zone "domain2.com" {
        type slave;
        file "/var/named/slaves/domain2.com.hosts";
        masters {
                xxx.xxx.xxx.xxx;
                xxx.xxx.xx.xx;
                };
        };

zone "domain3.com" {
        type slave;
        file "/var/named/slaves/domain3.com.hosts";
        masters {
                xxx.xxx.xxx.xxx;
                xxx.xxx.xx.xx;
                };
        };

zone "domain4.com" {
        type slave;
        file "/var/named/slaves/domain4.com.hosts";
        masters {
                xxx.xxx.xxx.xxx;
                xxx.xxx.xx.xx;
                };
        };
Domain4 is the one that's just been added & isn't working properly.
 
Old 05-12-2012, 09:00 AM   #6
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,458

Rep: Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941
Two different threads on the same topic have been merged. Please, keep the discussion in one place (here) to avoid confusion and to receive a more suitable and effective help. Thank you.
 
  


Reply

Tags
bind, centos, dns


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Install Wine - conflict with other installed software gwynn Ubuntu 9 04-29-2008 01:39 PM
Programs installed with package manager aren't recognised by other programs fraserm Linux - Software 3 04-21-2007 12:38 PM
apt4rpm vs YaST - no conflict, correct? Well, where are my programs? lefty.crupps Suse/Novell 7 01-16-2006 09:32 AM
Conflict with sound with WinTV Go card installed LinuxLuvr Linux - Hardware 7 01-17-2005 07:54 AM
How to get newly installed programs in programs list Brosky Linux - Software 5 02-06-2004 03:45 PM


All times are GMT -5. The time now is 08:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration