LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 05-09-2007, 02:46 PM   #1
officecase
Member
 
Registered: Jan 2007
Distribution: Centos, ArchLinux
Posts: 38

Rep: Reputation: 17
init 5 error will not start gome UI


I have installed centos 5 64bit server. The graphical install went just fine. Same goes for the first boot. Once the first boot made me reboot, that is where I have the problem. The os starts fine I get the graphical startup, I see all the services starting. I then am prompted at a shell login. Normally I should be loaded into my gnome desktop. I just sit at the login prompt. So I log in as root. Then issue a startx and I am told that the server is already running.

If I change the init to 3 and then restart the server, at the shell I issue startx and all is fine.
Once I change the run level back to 5 I have the same problem.

Last edited by officecase; 05-09-2007 at 02:49 PM.
 
Old 05-09-2007, 06:51 PM   #2
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 70
Perhaps your gdm (or whatever you use) is actually already running, just on a different tty than what you see…
Try cycling through your ttys (Alt-Right) until you come back to your original. If, along the way, you passed the graphical login screen, it seems it actually is running.

Now, the only problem is to figure out why it doesn’t just stay at the graphical login (i.e., why does it insist on changing vt).
 
Old 05-10-2007, 12:27 PM   #3
officecase
Member
 
Registered: Jan 2007
Distribution: Centos, ArchLinux
Posts: 38

Original Poster
Rep: Reputation: 17
You are correct! A few taps of the Alt-right, and blam! I have my graphical login screen. Thanks for that tip! Now I just have to figure out why it is changing screens. Maybe I will report it as a bug. It has only happened on this one computer. In my Vm I have no problems. I think I will try the x86 version and see if I can recreate the problem.
 
Old 05-10-2007, 05:49 PM   #4
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 70
If you really need to have it change terminal after starting, you might try putting a “chvt 7” (use whatever number works) somewhere in the boot sequence. See also: man 1 chvt
 
Old 05-11-2007, 04:48 PM   #5
officecase
Member
 
Registered: Jan 2007
Distribution: Centos, ArchLinux
Posts: 38

Original Poster
Rep: Reputation: 17
Is there a start up file that changes the different vts? I was loking at the kick start and saw all the screen changes. Does anyone know if there is a file for the boot that I can change? Or do I have to declare it in grub?
 
Old 05-11-2007, 06:01 PM   #6
officecase
Member
 
Registered: Jan 2007
Distribution: Centos, ArchLinux
Posts: 38

Original Poster
Rep: Reputation: 17
Well I ended up adding chvt 7 in the /etc/rc.local file and that did the trick. But I am still curious if there is another file that just wasn't formated properly at the time of the install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot start Gome or KDE .. HELP PLZ? cocheese Slackware 11 10-02-2004 08:34 AM
error: No init found. Try passing the init= option to the Kernel neylitalo Linux - Laptop and Netbook 3 01-22-2004 10:34 PM
help!...suse 9 gome won't shut off...or start reillac Linux - Newbie 14 01-03-2004 05:17 PM
Problem with Gome on Redhat 7.3 lansman Linux - Newbie 2 06-10-2003 08:41 AM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 11:18 PM


All times are GMT -5. The time now is 07:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration