LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 12-31-2012, 02:37 PM   #1
deranjer
LQ Newbie
 
Registered: Jan 2010
Posts: 5

Rep: Reputation: 0
Incorrect metadata area header checksum on /dev/sdb1 at offset 4096


Not very familiar with lvm, but I recently extended it... and now have the following issue:

Code:
$pvs
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  WARNING: Volume Group pve is not consistent
  PV         VG   Fmt  Attr PSize   PFree
  /dev/sda2  pve  lvm2 a--   74.03g  49.53g
  /dev/sdb1  pve  lvm2 a--  931.51g  31.51g
  /dev/sdd2  pve  lvm2 a--  931.87g 698.90g
Code:
$vgscan
  Reading all physical volumes.  This may take a while...
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  WARNING: Inconsistent metadata found for VG pve - updating to use version 78
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Automatic metadata correction failed
  Recovery of volume group "pve" failed.
Code:
 $lvdisplay
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  --- Logical volume ---
  LV Path                /dev/pve/swap
  LV Name                swap
  VG Name                pve
  LV UUID                fGB0zs-7WIQ-3BN8-eL9a-7YiE-5dDY-d70viT
  LV Write Access        read/write
  LV Creation host, time ,
  LV Status              available
  # open                 1
  LV Size                5.00 GiB
  Current LE             1280
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:1

  --- Logical volume ---
  LV Path                /dev/pve/root
  LV Name                root
  VG Name                pve
  LV UUID                f0mVM9-2A1I-zV0W-Mepm-ibF7-W4G5-PWaDoT
  LV Write Access        read/write
  LV Creation host, time ,
  LV Status              available
  # open                 1
  LV Size                18.50 GiB
  Current LE             4736
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:0

  --- Logical volume ---
  LV Path                /dev/pve/data
  LV Name                data
  VG Name                pve
  LV UUID                6q19dx-4rRa-f7wJ-nPf7-HmeQ-91OB-dohVK6
  LV Write Access        read/write
  LV Creation host, time ,
  LV Status              available
  # open                 1
  LV Size                1.11 TiB
  Current LE             290040
  Segments               2
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:2

  --- Logical volume ---
  LV Path                /dev/pve/vzsnap-proxmox-0
  LV Name                vzsnap-proxmox-0
  VG Name                pve
  LV UUID                hLRPqc-Nd8O-GhuI-ykZB-chqE-617d-F6cwHZ
  LV Write Access        read/write
  LV Creation host, time proxmox, 2012-12-22 00:00:04 -0500
  LV Status              available
  # open                 0
  LV Size                1.00 GiB
  Current LE             256
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:3
However, everything appears to be working. My data is still there, everything is mounted, however I want to get rid of that error.


Code:
$mount
/dev/mapper/pve-root on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/mapper/pve-data on /var/lib/vz type ext3 (rw)
/dev/sda1 on /boot type ext3 (rw)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
/dev/fuse on /etc/pve type fuse (rw,nosuid,nodev,default_permissions,allow_other)
beancounter on /proc/vz/beancounter type cgroup (rw,name=beancounter)
container on /proc/vz/container type cgroup (rw,name=container)
fairsched on /proc/vz/fairsched type cgroup (rw,name=fairsched)
/dev/sdc1 on /mnt/backups-folder type ext4 (rw,noexec,nosuid,nodev)


Even though it is working (or appears to be) I did attempt to follow these directions:
http://tldp.org/HOWTO/LVM-HOWTO/recovermetadata.html

They did not work, as the lvm is running..
Code:
pvcreate --uuid "Pbyrpl-oYOq-ZzBq-8wW6-k31d-qckK-SU5LF3" --restorefile /etc/lvm/archive/pve_00042-1602581271.vg /dev/sdb1

 Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Incorrect metadata area header checksum on /dev/sdb1 at offset 4096
  Can't open /dev/sdb1 exclusively.  Mounted filesystem?
Since the lvm appears to be working, what should I do to get this issue corrected?
 
  


Reply

Tags
lvm, metadata, mounted


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Metadata does not match checksum malak33 Linux - Server 2 08-23-2012 11:35 PM
My pendrive suddenly changed from /dev/sda1 to /dev/sdb1! stf92 Slackware 10 08-08-2012 05:02 PM
mdadm --manage /dev/md0 --add /dev/sdb1 returns device busy JeepingAZ Linux - Desktop 2 02-17-2011 12:18 PM
metadata file does not match checksum ? anilbh Fedora 4 04-15-2007 12:08 PM
LVM Error: incorrect metadata area header checksum neillans Linux - General 1 02-28-2006 02:06 PM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration