LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-02-2007, 06:41 AM   #1
skyplus
LQ Newbie
 
Registered: Dec 2007
Posts: 2

Rep: Reputation: 0
I cannot start httpd service


It was good several days ago, but now i can't get it started.
Please help me figure out why. Thanks!

#service httpd statushttpd is stopped

#service httpd startedStarting httpd: [Sun Dec 02 19:34:56 2007] [warn] module python_module is already loaded, skipping
httpd: Could not determine the server's fully qualified domain name, using 192.168.1.201 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down
Unable to open logs
[FAILED]

#netstat -lnp |grep 80
tcp 0 0 0.0.0.0:5280 0.0.0.0:* LISTEN 6079/lmgrd
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN -
udp 0 0 0.0.0.0:10080 0.0.0.0:* 4964/xinetd
 
Old 12-02-2007, 07:00 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
it says the address is already in use... apache is probably already running...
 
Old 12-02-2007, 07:08 AM   #3
skyplus
LQ Newbie
 
Registered: Dec 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by acid_kewpie View Post
it says the address is already in use... apache is probably already running...
Thanks for your help
But httpd is not running, right?
actually i just want to use svn&trac with httpd,
but now they cann't be browsed with webexplorer any more...
whth shall i do?
 
Old 12-02-2007, 07:14 AM   #4
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
Code:
# lsof -i
May be some process is already listening on the 80 port.
You can use this command to see which program. Then kill it and start apache.
 
Old 12-04-2007, 05:34 AM   #5
mt83
LQ Newbie
 
Registered: May 2007
Distribution: RedHat 9, ES4, CentOS4
Posts: 16

Rep: Reputation: 0
Hi,

That what i faced before. hope you help. I got solution from one forum.
I can solve it with below steps.

error - make_sock: could not bind to address 0.0.0.0:443 or 80

the prblem is with the port conflict..how can u track it..

#lsof -i :80 - check

bash 19089 root 18u IPv4 127053 TCP *:http (LISTEN)

#kil -9 19089 - kill

#lsof -i :80 - recheck

#apachectl start - finish
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to start apache :Starting httpd: Syntax error on line 1027 of /etc/httpd/conf/ payjoe Linux - Newbie 3 09-21-2007 08:24 AM
Service httpd Start bajpaipuneet Linux - Server 1 03-07-2007 06:22 PM
httpd service won't start GavB Linux - Newbie 4 01-19-2007 08:56 AM
service httpd status, results in httpd dead but subsys locked squadja Red Hat 2 09-11-2004 11:31 PM
httpd as a service joshf Linux - Software 5 07-10-2003 08:54 AM


All times are GMT -5. The time now is 12:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration