LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Hylafax and Salsafax (http://www.linuxquestions.org/questions/linux-server-73/hylafax-and-salsafax-763388/)

Shadak 10-21-2009 03:47 AM

Hylafax and Salsafax
 
Hey guys,

In the company where I work they want a new faxserver.
So I installed Hylafax, this works like a charm.
The sendFax command works and the winPrint tool works to.
What I realy want is for users to print to the faxserver so they don't need to manualy type the fax number.
This brought me to Salsafax (formerly know as sambafax)

I followed this and thishow to.
The installation was no problem but when I try to test this with the
Quote:

lpr -P SalsaFax testFax
The script does not run.
In my cubs web portal, the print job says it's finished.

does anybody know what I did wrong?

quick summary of my settings:
openSuse 11
Cups
Hylafax and Salsafax + dependencies

UPDATE: the printer I added wrote the fax to my script file.
My URI had to be pipe:/usr/lib/cups/backend/salsafax.pl

apventer 11-19-2009 07:58 AM

OK Shadak, I am experiencing the same problem as you - the PERL script gets overwritten when using the lpr command. I am unable to use the -v pipe:/usr/lib/cups/backend/salsafax.pl option in lpadmin. How did you do it???

nyh 05-20-2010 07:01 PM

Quote:

Originally Posted by apventer (Post 3762650)
OK Shadak, I am experiencing the same problem as you - the PERL script gets overwritten when using the lpr command. I am unable to use the -v pipe:/usr/lib/cups/backend/salsafax.pl option in lpadmin. How did you do it???

I had an evening of trouble too (CUPS 1.4.2 on FreeBSD 8.0). Finally this worked:
Quote:

Originally Posted by printers.conf
<Printer SambaFax>
Info SambaFax
MakeModel Generic PostScript Printer
DeviceURI salsafax.pl:/
State Idle
StateTime 1274398519
Type 8400964
Filter application/vnd.cups-raw 0 -
Filter application/vnd.cups-command 0 commandtops
Filter application/vnd.cups-postscript 0 -
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

The big secret is in the:
DeviceURI salsafax.pl:/
That makes things work.


All times are GMT -5. The time now is 01:24 AM.