LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   HOWTO : Disable Reverse Name Resolution Security Procedure at SSH Client End (http://www.linuxquestions.org/questions/linux-server-73/howto-disable-reverse-name-resolution-security-procedure-at-ssh-client-end-906550/)

harmandeep 10-05-2011 07:37 AM

HOWTO : Disable Reverse Name Resolution Security Procedure at SSH Client End
 
Setup follows as :-

(1) http://www.linuxquestions.org/questi...tempts-839740/
Then follow below text :-

Guys, as suggested above in (1) is to configure SSHD config. so as to prevent above msgs to incurr in SSHD Server /var/log/secure (or the one configured).

Now same sort of MSG PROMPT are also generated on SSH Client,
which can be are viewable using -v option and also without -v option, depicted below ...

SSH Client :-

[root@rhel-52-01]# ssh root@49.201.15.213 -p 12547 -v {Output Excerpt}

reverse mapping checking getaddrinfo for static-213.15.201.49.tataidc.co.in failed - POSSIBLE BREAK-IN ATTEMPT!



SSHD Daemon (Server) : SSHD /var/log/secure EXCERPT:-

Sep 14 02:15:34 rhel-52-01 sshd[27925]: reverse mapping checking getaddrinfo for static-078.244.156.182.tataidc.co.in failed - POSSIBLE BREAK-IN ATTEMPT!

Now for SSHD, UseDNS directive does the job of not attempting Reverse name
resolution for verifying INCOMING SSH Client DNS Authenticity.( as said above)


Now, is there any option to configure SSH Client component( @ the Client END ),so it doesn't attempts REVERSE name Resolution ( as seen in ABOVE TRUNCATED Output of ssh -v ) ???

Regards

rodrifra 10-05-2011 08:17 AM

Have you tried the same as for the server but in your config file ~/.ssh/config?

harmandeep 10-06-2011 04:28 PM

i had used Global Config files ... i.e. beneath /etc


All times are GMT -5. The time now is 04:26 PM.