LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-24-2006, 02:19 PM   #1
mikey
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Rep: Reputation: 0
Unhappy Help: X on CentOS w/Windows CygwinX client


Hi, I just built a CentOS box with everything installed. I thought I could just startx and connect... My 1st attempt:

[root@centos1 bin]# /usr/X11R6/bin/startx

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

Please consult the The X.Org Foundation support
at http://wiki.X.Org for help.

Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.


So then I found this FAQ http://wiki.x.org/wiki/FAQErrorMessa...4995fac710a6a9 and attempted to startx accordingly:

[root@centos1 bin]# /usr/X11R6/bin/startx -- :1
\
X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.9-42.ELsmp i686 [ELF]
Current Operating System: Linux centos1.mikey.com 2.6.9-42.ELsmp #1 SMP Sat Aug 12 09:39:11 CDT 2006 i686
Build Date: 22 August 2006
Build Host: build-i386

Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.9-42.ELsmp (buildcentos@build-i386) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP Sat Aug 12 09:39:11 CDT 2006
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sun Dec 24 11:53:42 2006
(==) Using config file: "/etc/X11/xorg.conf"

SESSION_MANAGER=local/centos1.mikey.com:/tmp/.ICE-unix/6989
AUDIT: Sun Dec 24 11:53:45 2006: 6943 X: client 6 rejected from local host

** (gnome-panel:7046): WARNING **: Unable to load panel stock icon 'gnome-debian'


** (gnome-panel:7046): WARNING **: Unable to load panel stock icon 'gnome-suse'

looking for type: got text/plain
looking for type: got application/x-gnome-app-info
looking for type: got text/plain
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90: GtkDeprecationWarning: gtk.mainloop is deprecated, use gtk.main instead
self.warn(message, DeprecationWarning)


So I'm not even sure at this point if it is running or not, but I then go to Cygwin bash shell on my Windows PC to connect via X:

$ ssh -Y -l mikey 192.168.25.1
mikey@192.168.25.1's password:
Last login: Sun Dec 24 11:14:07 2006 from xp1.mikey.com
[mikey@centos1 ~]$ xterm&
[1] 7125
[mikey@centos1 ~]$ xterm Xt error: Can't open display:


What am I missing? Any advice would be greatly appreciated. Thanks.
 
Old 12-24-2006, 02:24 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Ok what happens when the system boots up. Does it goto a gui login manager or to a console session?
Has X worked before?
What video card do you have?
Post contents to /etc/X11/xorg.conf
If the file /tmp/.X0-lock exist delete it and just type startx.

Brian
 
Old 12-24-2006, 02:36 PM   #3
mikey
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Smile

Thanks Brian,

When I boot up, it goes to the CentOS GUI and upon logon I get the nice looking desktop that looks like Windows. So I guess X server is running, and I just can't get to it remotely.

X has never worked, but I'm sure I'm doing something wrong on the Windows machine.

Video card is a low-end nVidia: GeForce 7300LE 256MB TurboCache. On the CentOS box when I go to display settings it thinks my video card is the VESA driver (generic) and it's working fine.

There is no .X0-lock file in /tmp.

Contents of /etc/X11/xorg.conf file:

[root@centos1 X11]# more xorg.conf

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "DELL E177FP"
DisplaySize 340 270
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "VESA driver (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

[root@centos1 X11]#
 
Old 12-24-2006, 02:54 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Ok X is working. Now what are you using to connect to from the Windows machine?
From a reread looks like you are using cgywin which I nevered used. But here is a thought. Are you trying to redisplay display:0?
Is there a link to site you are using to set this up? If so post link.

Brian
 
Old 12-24-2006, 03:01 PM   #5
mikey
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Red face

I tried CygwinX and get the error:

[mikey@centos1 ~]$ xterm Xt error: Can't open display:

So then I downloaded a trial of X-Win32 and changed the session settings to display:1. Upon launch of the session it just hangs with:

Status: waiting for query response from host

The only site I'm using to set this up is the X.org wiki: http://wiki.x.org/wiki/FAQ

What X client do you use, maybe I should try that one?
 
Old 12-29-2006, 06:18 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Sorry for the delay. Lots of shutdown overtime work.
Not familiar with cygwinx so not sure what to look at.

Brian
 
Old 01-01-2007, 10:16 PM   #7
jfxberns
LQ Newbie
 
Registered: Mar 2003
Posts: 18

Rep: Reputation: 0
Enable XDMCP in Login Screen Setup, Check Firewall Settings

To enable XDMCP:

Applications --> System Settings --> Login Screen

Click on XDMCP tab and select "Enable XDMCP"

You should now be able to login from a remote computer using cygwin.

If you still cannot log into XWindows remotely, you might also want to check if you have the firewall enabled on your Linux system (in CentOS, Fedora Core and RedHat, the default setting on installation is "Firewall Enabled"), that can block access to the ports necessary for XWindows.

Applications --> System Setting --> Security Level

and try disabling the firewall. If that fixes it, and you cannot live without a firewall, you will have to re-enable the firewall and make a custom exception for xWindows. Do a search for how to do that...

Last edited by jfxberns; 01-02-2007 at 01:35 AM.
 
Old 01-02-2007, 12:47 AM   #8
mikey
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks! That worked!

-Michael
 
  


Reply

Tags
centos, gdm, gnome, kde, xdmcp, xterm, xwindows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 4.0 + Windows XP Dual Boot laserlight Linux - Enterprise 9 02-01-2010 12:51 PM
Telnet Client / CentOS riluve Red Hat 2 10-13-2006 10:51 AM
can not connect to my pureftp server from Linux client, but i can from windows client bonito Suse/Novell 5 03-16-2005 09:45 PM
Windows + cygwinX+fedora2+kde Grem Linux - Software 0 10-15-2004 11:50 AM
Apache/SSL - works with Windows client but not Linux client RickHDYoung Linux - Security 1 07-01-2004 04:02 PM


All times are GMT -5. The time now is 04:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration