LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-23-2010, 05:05 AM   #1
BasicInc
LQ Newbie
 
Registered: Feb 2010
Posts: 1

Rep: Reputation: 0
General authentication problem - significant delay after pass entered / PAM_unix


Hi all.

My first post here. I've been using Ubuntu Server edition (Hardy) happily for some time now. I use sudo regularly during configuration of new services. It always works/authorises within seconds, however, it recently became very slow, to the point of being nearly unusable. It turns out that ANY authentication request stalls in this way - in in a plain shell, X or Gnome, via VNC (and even FTP seems affected).

In /var/log/auth.log I noticed a regular working pattern like this:

Feb 3 14:07:20 kanyo sudo: lee : TTY=pts/1 ; PWD=/usr/share/obm/www ; USER=root ; COMMAND=/etc/init.d/apache2 restart
Feb 3 14:07:25 kanyo sudo: pam_unix(sudo:session): session opened for user root by lee(uid=0)
Feb 3 14:07:30 kanyo sudo: pam_unix(sudo:session): session closed for user root

Unfortunately now, these records look the same, but the timestamps are much wider apart (minutes). The problem occured after running synaptic and dpkg-reconfigure obm-conf. I was trying to remove 'OBM' (http://www.obm.org/doku.php?id=docs:install:ubuntuhardy) completely as I'd messed up (just OBM) while trying to fix a minor-looking misconfiguration.

Any idea what I've broken and how to fix it?

I've carefully analysed which files were altered (modified) during my changes (as the problem survives a reboot), but there are no likely-looking candidates in the list (I deleted some blank lock files). I also did a wireshark capture during an authentication session and noticed that it doesn't appear to be looking off the server for information (I had likewise-open installed, but the problem exists whether that is running or not).

Research in the forums hinted that this might just be as simple as a bad /etc/hosts file - but /etc/hosts has not been modified. I may have a flawed DNS, but I get fast enough responses to nslookup and can access Internet etc.

Any help much appreciated.

Regards,

Lee
 
Old 02-23-2010, 09:55 AM   #2
CircleDown
LQ Newbie
 
Registered: Aug 2009
Posts: 7

Rep: Reputation: 0
Lee,

I have the same problem, and I am running the same distribution as you are. Unfortunately I cannot tell you how to fix it, but I believe I can tell you how to figure out what the problem is:

As long as you have the capabilities to do so, disconnect your server from your network and from the internet so that the only thing that is plugged in is the power supply, then try to authenticate again.

If you are like me, it will come up in seconds, as opposed to the 3+ minute hang. If that's the case, I think you can safely assume that you have a resolution problem somewhere. Keyword unfortunately is somewhere.

Also, maybe restart /etc/hosts?

Let me know if you figure it out, and I will do the same.

Last edited by CircleDown; 02-23-2010 at 09:57 AM.
 
  


Reply

Tags
authentication, pam


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
delay - authentication falure slack_prad Linux - General 1 12-26-2006 04:20 AM
pam_unix in logfile jkmartha Linux - Newbie 1 05-04-2005 09:40 PM
MySQL :: Table in query adds significant delay lackluster Programming 7 07-10-2004 03:48 AM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration