LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 10-05-2009, 04:44 AM   #1
speedsrfr
LQ Newbie
 
Registered: Jul 2005
Distribution: fedora 17
Posts: 22

Rep: Reputation: 0
freenx (remote control) display problem, unclean shutdown


Hi
I started using the gpl version of nomachine nx remote control software because of its good support for my international keyboard unlike vnc, and because of the speed.

Unfortunately every time I turn off the remote pc with the powerbutton and forget to close off my nx session i was running from my laptop, it records this, and even if I run
Code:
nxserver --cleanup
or
Code:
nxserver --history -clear
the next time i boot the computer, the connection I make from my laptop is on a new display. For example I connected on display 1000 (normal base display for nx) then I had an unclean shutdown and the next time i connected it made me use 1001. Ive had a few more mishaps and Im at 1005 now. Is there any way to clean this up. I tried
Code:
nxserver --uninstall --purge
and reinstalling the rpms but it doesnt work.
Please help. Thank you.
 
Old 10-06-2009, 08:03 AM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
Hi,

I think the dead sessions are probably being tracked on your laptop, try looking in ~/.nx

cheers
 
Old 10-07-2009, 02:19 AM   #3
speedsrfr
LQ Newbie
 
Registered: Jul 2005
Distribution: fedora 17
Posts: 22

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by kbp View Post
Hi,

I think the dead sessions are probably being tracked on your laptop, try looking in ~/.nx

cheers

I uninstalled nx on the laptop and reinstalled it and made sure .nx was deleted so it would have to create a new one.
I get a lot of these errors on connection i usually just restart the nxserver and then it users a new display. I then connected again and made sure nx owned the var/lib/nxserver directory, the eroor dissapeared but it didnt help it still used display 1005 instead of 1000. *sigh* do I really have to reinstall my entire system? surely not. I use a windows client from nomachine if that makes a difference
Code:
NX> 203 NXSSH running with pid: 3792
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.0.102 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 105 hello NXCLIENT - Version 2.1.0
NX> 134 Accepted protocol: 2.1.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: roland
NX> 102 Password: 
NX> 103 Welcome to: susefilesrv user: roland
NX> 105 listsession --user="roland" --status="suspended,running" --geometry="1280x1024x32+render" --type="unix-kde"
NX> 127 Sessions list of user 'roland' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: roland
NX> 105 startsession  --link="adsl" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="testing" --type="unix-kde" --geometry="1024x768" --client="winnt" --keyboard="pc102/ch" --screeninfo="1024x768x32+render" 

NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 700 Session id: susefilesrv-1005-15BF4F4CCBD38F2D9722B5EE24C46888
NX> 705 Session display: 1005
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: 29ac033b9fb85725367ef331a3c34a36
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 29ac033b9fb85725367ef331a3c34a36
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
NX> 105 NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate "/home/roland/.nx/F-C-susefilesrv-1005-15BF4F4CCBD38F2D9722B5EE24C46888/session". You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to test the basic functionality. Session log follows:
/usr/bin/nxserver: line 1371: 12775 Terminated              sleep $AGENT_STARTUP_TIMEOUT
Can't open /var/lib/nxserver/db/running/sessionId{15BF4F4CCBD38F2D9722B5EE24C46888}: No such file or directory.
NX> 1006 Session status: closed
mv: cannot stat `/var/lib/nxserver/db/running/sessionId{15BF4F4CCBD38F2D9722B5EE24C46888}': No such file or directory
NX> 1001 Bye.
NX> 280 Exiting on signal: 15

Last edited by speedsrfr; 10-07-2009 at 02:25 AM.
 
Old 10-07-2009, 04:46 PM   #4
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
It doubt it would make a difference whether you are running on Windows, have you tried verifying the package install? ('rpm -V nxserver?')
.. does it really matter if the display number keeps incrementing ?
 
Old 10-10-2009, 03:23 AM   #5
speedsrfr
LQ Newbie
 
Registered: Jul 2005
Distribution: fedora 17
Posts: 22

Original Poster
Rep: Reputation: 0
i tried but rpm -v gives verbose says the rpm help, not verify.
Maybe it doesnt matter. and I should just give it up as a bad job. Im open to any other ideas. but thanks very much for your help so far.
 
Old 10-10-2009, 08:27 AM   #6
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
That's a capital 'V' not a lowercase one

v = version
V = verify

cheers
 
  


Reply

Tags
admin, remote


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'shutdown' command causing unclean shutdown silentwol Linux - Software 3 07-01-2009 02:01 AM
Software to Display a Large Menu for Remote Control? bt101 Linux - Software 4 03-09-2008 03:03 PM
Unclean shutdown...now...... S...L....O....W LarryFrigginWachs Linux - Newbie 4 12-29-2006 02:28 PM
Guaranteed filesystem corruption on unclean shutdown? pigsa Linux - Software 7 12-10-2006 06:41 AM
SASEM Vacuum Florescent Display + Remote control drivers lucius Linux - Hardware 0 05-20-2004 09:48 AM


All times are GMT -5. The time now is 05:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration