LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   ffmpeg extension won't load after php version upgrade from 5.1.6 to 5.2.13 (http://www.linuxquestions.org/questions/linux-server-73/ffmpeg-extension-wont-load-after-php-version-upgrade-from-5-1-6-to-5-2-13-a-824191/)

kdani 08-04-2010 03:15 PM

ffmpeg extension won't load after php version upgrade from 5.1.6 to 5.2.13
 
CentOS 5, installed ffmpeg and compiled the ffmpeg.so, from fffmpeg-php-0.6.0. Everything works fine. Then upgrade the php to 5.2.13 (using an external repository)

recompiled ffmpeg.so but now when trying to load php:

PHP Warning: PHP Startup: ffmpeg: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=0
PHP compiled with module API=20060613, debug=0, thread-safety=0
These options need to match
in Unknown on line 0

Any ideas how to resolve this issue ? Thanks.

bathory 08-04-2010 05:05 PM

Hi,

You can (re)move ffmpeg.so and then in the ffmpeg-php sources directory run
Code:

phpize -clean
After that redo the installation

Regards

kdani 08-04-2010 11:42 PM

Quote:

Originally Posted by bathory (Post 4056036)
Hi,

You can (re)move ffmpeg.so and then in the ffmpeg-php sources directory run
Code:

phpize -clean
After that redo the installation

Regards

Thanks !! it worked !

(ffmpeg is now appears on phpinfo, although make test says it fails)
but the versions problem is gone.


All times are GMT -5. The time now is 03:15 PM.