LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Fedora16 Wake on Lan (http://www.linuxquestions.org/questions/linux-server-73/fedora16-wake-on-lan-938851/)

guna_pmk 04-09-2012 05:05 AM

Fedora16 Wake on Lan
 
Hi Guys,

I have a CentOS server (5.5 x64) which regularly wakes up a machine and instructs it to perform some jobs. Previously that remote machine used to be Fedora14 32bits and the wake on lan used to work. For various reasons (including using 6G of memory) I recently switched over to Fedora16 64bits. But my wake on lan stopped working.

I have the following on the Fedora 16 side (nothing changed on the CentOS side since the Fedora14 time; the hardware on the Fedora side did not change either):

Code:

Kernel - 3.3.1-3.fc16.x86_64
Ethernet device - Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
Result of ethtool em1 :
        Supported ports: [ TP MII ]
        Supported link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: g
        Current message level: 0x000000ff (255)
                              drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

Please let me know if you need more information in this regard.

Thanks

TB0ne 04-09-2012 10:20 AM

Quote:

Originally Posted by guna_pmk (Post 4648153)
Hi Guys,
I have a CentOS server (5.5 x64) which regularly wakes up a machine and instructs it to perform some jobs. Previously that remote machine used to be Fedora14 32bits and the wake on lan used to work. For various reasons (including using 6G of memory) I recently switched over to Fedora16 64bits. But my wake on lan stopped working.

I have the following on the Fedora 16 side (nothing changed on the CentOS side since the Fedora14 time; the hardware on the Fedora side did not change either):

Putting this in to Google pulls up a known bug-report:
https://bugzilla.redhat.com/show_bug.cgi?id=794788

Appears to be a known issue, and that they're working on it.

guna_pmk 04-10-2012 04:12 AM

Thanks TBOne. In the link you provided, in comment 6 Patrick has got the problem solved. If you see comments 7, 8 and 9 there is no reply since 29th (about 10 days). And if you look at the names on those comments it is myself ;). I threw the question here as there is no reply for some time from them :).

Thanks

TB0ne 04-10-2012 09:58 AM

Quote:

Originally Posted by guna_pmk (Post 4649019)
Thanks TBOne. In the link you provided, in comment 6 Patrick has got the problem solved. If you see comments 7, 8 and 9 there is no reply since 29th (about 10 days). And if you look at the names on those comments it is myself ;). I threw the question here as there is no reply for some time from them :).

Thanks

Names were the same, but there's no way to know the same person from forum to forum. The bug has been reported as CLOSED, and if you knew the problem existed and has been solved, and knew where to go for the solution, why post here? Did you read the post from 3/22/2012?
Code:

Dave Jones 2012-03-22 13:14:29 EDT

[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.


guna_pmk 04-11-2012 04:39 AM

Hi TBOne,

It's my mistake. I did not notice that the bug was closed. As mentioned in the post, I still have not got the problem solved; that is why I raised it here as this forum is more active and have people using diverse distributions.

I have created a new bug there again there https://bugzilla.redhat.com/show_bug.cgi?id=811478.

Thanks

TB0ne 04-11-2012 10:43 AM

Quote:

Originally Posted by guna_pmk (Post 4649947)
Hi TBOne,

It's my mistake. I did not notice that the bug was closed. As mentioned in the post, I still have not got the problem solved; that is why I raised it here as this forum is more active and have people using diverse distributions.

I have created a new bug there again there https://bugzilla.redhat.com/show_bug.cgi?id=811478.

Thanks

Are you using the kernel update that was suggested in that thread?? If not, you don't have the fix applied.

guna_pmk 04-12-2012 09:37 AM

Yes, I have updated the kernel. Still the problem is there.

Thanks

mail2ganesh.cse 05-01-2012 04:36 AM

[root@dlp ~]#
yum -y install ethtool
[root@dlp ~]#
ethtool -s eth0 wol g

[root@dlp ~]#
vi /etc/sysconfig/network-scripts/ifcfg-eth0
# add at the last line

ETHTOOL_OPTS="wol g"
[root@dlp ~]#
ifconfig eth0 | grep HWaddr | awk '{print $5}'

00:22:68:5E:34:06
# take a memo
[root@dlp ~]#
shutdown -h now


[root@wol ~]#
yum -y install net-tools
# ether-wake [MAC address of the computer you'd like to turn on]

[root@wol ~]#
ether-wake 00:22:68:5E:34:06

# send magick packets


All times are GMT -5. The time now is 03:35 AM.